• I am having issues since upgrading from 0.32 to 1.2 that some machines fail at network boot now we have 60 machines that are all identical and all boot except for the odd on I would say somewhere between 10 and 20 come up with this error PXE-E32: TFTP open timeout I am not sure what is causing this any help would be appreciated.


  • I was on Ubuntu before switching to Debian and had to run the “restart tftp-hpa” command on a regular basis.

  • Well definitely spoke to soon even after the updates I am still forced to run this command every so often “restart tftpd-hpa” which fixes the issue usually for about an hour sometimes a lot less I will be making a new install using 12.04.4 LTS server I haven’t heard anything bad about that one.

  • Well so far it’s looking like the updates may have fixed my issues I haven’t had a TFTP timeout since the update so I will keep you posted if it starts up again.

  • Developer

    [quote=“Wolfbane8653, post: 42224, member: 3362”]Hopefully this will help you with some questions on your OS decisions.

    most of those are pretty outdated, and only have instructions for installing 0.32

  • Developer

    Hopefully this will help you with some questions on your OS decisions.

  • Yeah if this doesn’t work I will make a new server using 12.04 its what I used in the pass and it worked flawlessly. Didn’t think that would be such a big issue.

  • Yeah before the upgrade I was using 12.04 but thought it would be safe to update the server as well I was suspecting it was the problem but its so hit and miss it was making it tough to trouble shoot.

  • Developer

    [quote=“Tom Elliott, post: 42212, member: 7271”]My basic guess.

    Option 67/filename is still set to pxelinux.0. In FOG 1.x.x, the file name should be changed to undionly.kpxe.[/quote]

    Just for future reference you will see changing this dhcp option in the wiki guide to upgrade from 0.32 to 1.x.x. You may want to reference this for other changes.

    Ubuntu 14.04 is known for randomly crashing apache2 and tftp. I believe they have released updates to correct this. Try doing:
    [CODE]sudo apt-get update
    sudo apt-get upgrade
    This should update all your packages. [U]Hopefully[/U] this doesn’t break anything.

  • Developer

    i would recommend almost any other version of Ubuntu over 14.04 LTS. many people have gotten fog to work fine on it, but many people haven’t as well. i personally use Ubuntu 12.04 LTS and have had very few issues.

  • Yeah I updated it to the undionly.kpxe when I did the upgrade normally it boots right away into the fog menu takes like 2 to 3 seconds but when it goes south after about 20 seconds it times out. Now I am starting to believe the problem is server related I got one machine to image by restarting the fog server it seems that apache2 is randomly crashing but only on certain things it appears everything is working till you log into the fog server and there is a ton of errors. I am using Ubuntu 14.04LTS is there a different version I should be using or a different OS? We have been using this for 4 to 5 years now and this is the only hic up we have ever seen this is an excellent product especially when you have no budget.

  • Senior Developer

    My basic guess.

    Option 67/filename is still set to pxelinux.0. In FOG 1.x.x, the file name should be changed to undionly.kpxe.

  • Developer

    how long do the clients take before they timeout? how long do they normally sit at the network boot screen before they pick up the network boot file?

  • Senior Developer

    Is it always the same machines failing or randomly?? Not easy to track down if it happens randomly I suppose. You can capture all TFTP traffic on the FOG server but might be pain in the ass to go through that packet dump afterwards and find out about those failed clients. TFTP is not the easiest protocol to capture/filter as it uses unknown port numbers when transfering data.
    Start off with capturing just the TFTP requests on your FOG server:
    [CODE]sudo tcpdump -i eth0 -w tftp_requests.pcap port 69[/CODE]
    Copy the pcap file to your PC and open it using wireshark. See if you can find anything useful in there (like missing requests from some of your clients)…

    If you want to take it one step further and capture the TFTP answers too you’ll probably have to capture all UDP traffic. Setting ‘snaplen’ (-s) to a sensible number might give you a smaller pcap file and still have all the information you want. See ‘man tcpdump’ too.
    [CODE]sudo tcpdump -i eth0 -s 512 -w tftp_all.pcap udp[/CODE]

    Upload them to the forum if you want me to have a look at those packet dumps. I’ll see what I can find out.