"Printer Manager Sevice Disabled" regardless of configuration - FOG 1.1.0 12.04.4 Server LTS



  • Hi all,

    I’m having a problem with the newest FOG client on host machines that used to work in 0.32. I have a clean install of 1.1 on Ubuntu 12.04.4 LTS Server. I keep getting a “Printer Sevice Disabled” on the client in the FOG log when trying to add printers via the printer manager.

    Also, when I add a printer to a group of machines it doesn’t actually save the printer add. I have to manually go and add the printer to each individual host.

    Lastly, I used to be able to use the Local Printer option in printer management to install printers without needing to point to an INF as long as our image had the INF installed in the OS. You used to be able to put a fake INF driver location, then go back and modify to make it blank. What option would I use to be able to configure a network printer via IP without pointing to an INF location?

    Here’s the log:

    6/10/2014 9:40 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:42 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:43 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:43 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:44 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:44 AM FOG::PrinterManager Sevice is disabled.
    6/10/2014 9:45 AM FOG Service Engine Version: 3
    6/10/2014 9:45 AM Starting all sub processes
    6/10/2014 9:45 AM 2 modules loaded
    6/10/2014 9:45 AM * Starting FOG.HostRegister
    6/10/2014 9:45 AM * Starting FOG.PrinterManager
    6/10/2014 9:45 AM FOG::PrinterManager Starting interprocess communication process…
    6/10/2014 9:45 AM FOG::HostRegister Starting host registration process…
    6/10/2014 9:45 AM FOG::PrinterManager interprocess comm startup: OK
    6/10/2014 9:45 AM FOG::HostRegister Exiting because only 0 mac address was found.
    6/10/2014 9:46 AM FOG::PrinterManager Sevice is disabled.

    Thanks everyone!



  • No success Tom. All of the Surface Pros have SSDs so I think those parts of the error logs are because the OS boots up immediately and the network devices lag behind.

    I’ve seem to narrowed it down to the FOG client having a problem working in Windows 8.1 64 bit. I just tested the same thing with the FOG server and it works fine in Windows 7 32 bit. Even running the client as admin and in compatibility mode doesn’t fix the printer manager service is disabled issue.


  • Senior Developer

    Based on what I’m seeing:
    6/10/2014 9:45 AM FOG::HostRegister Exiting because only 0 mac address was found.

    That’s just that line, but the Printer Manager service would be sending the same thing. Is it sending MAC address to the server?

    If not, this is most likely the problem.



  • Hey Tom,

    Sorry about the late reply but the issue is still ongoing. I tried reinstalling the client, reinstalling FOG on the server twice, and no luck. Also tried running the installer as admin in windows but still the same result :(. The client’s OS is windows 8.1 x64 if that helps.

    EDIT: It does look like a problem with the FOG client. I’ve switched NICs and even when the MAC address for the client isn’t registered it still reports back as being disabled.



  • I had this same problem. I’ve tried everything even wiped out and reinstalled my fogserver but could not get it to work. I was playing around with Fogclient and somehow clicked on Run as administrator when installing. Restarted my host client. Ta…da…Problem solved. Tested on two more host clients. All is well. At least this fixed my problem. I hope it does to you too.

    Thanks Fog admins for all the hard work!.


  • Senior Developer

    What I’m going to recommend, maybe you’ve tried maybe not?

    Please try again:

    Go to the host that’s giving you issues.

    Uncheck all the services and save. Then recheck all the services and save, does the issue still occur?



  • Done!

    [url="/_imported_xf_attachments/0/953_printscreen.PNG?:"]printscreen.PNG[/url]


  • Senior Developer

    One last place, what’s the service setting for the host?



  • No problem! Here you go!

    [url="/_imported_xf_attachments/0/952_pmanagercapture.PNG?:"]pmanagercapture.PNG[/url]


  • Developer

    Thank you for giving Fog Configuration --> FOG Settings --> “FOG Service - Printer manager”

    Can you also post this location under services: Service Configuration --> “Printer Manager”

    Edit: Should look something like what I have attached.

    [url="/_imported_xf_attachments/0/951_Untitled.png?:"]Untitled.png[/url]



  • I can definitely post a screen of anything if it helps, but the only option for the printer manager settings under fog settings is enabled or disabled (checkmark or not checked) in which case I have it checked. Same thing for the individual hosts.

    [url="/_imported_xf_attachments/0/950_printermansettings.PNG?:"]printermansettings.PNG[/url]


  • Developer

    Just to be sure can you post a screen capture for Service Configuration --> “Printer Manager” & Fog Configuration --> FOG Settings --> “FOG Service - Printer manager”


Log in to reply
 

417
Online

39002
Users

10717
Topics

101762
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.