Lenovo P52 - Stuck on iPXE 1.20.1

  • Hey Everyone - I had this issue before when trying to capture my audit mode image. I can get the capture to happen on any of the other models of computers that we have but for some reason the Lenovo P52 doesn’t work. It’s just stuck on the the PXE screen. The last couple of lines that I see are:
    bzImage … ok
    init.xz… ok

    and it will just sit there forever, not picking up on the FOG side to start initiating the capture. Is this something someone else has experienced?

    Any pointing in the right direction would be much appreciated.


  • Moderator

    @austinjt01 said in Lenovo P52 - Stuck on iPXE 1.20.1:

    Yes still stuck at the handoff to FOS.

    One option you can try is to compile the latest version of iPXE. There has been some updates to iPXE since 1.5.9 has been released. There may be some value in trying the process outlined by Sebastian here: https://forums.fogproject.org/post/141618

    You will need the github version of the fog installer to follow these steps.

  • @jj-fullmer No I haven’t tried that. I will try that now. Thanks!

    I have checked in the FOG task manager to see if it shows any progress and unfortunately it doesn’t show anything.

  • @george1421 Yes still stuck at the handoff to FOS. I’ll try again today. Thanks!

  • Testers

    @austinjt01 Have you tried different versions of bzImage and or init.xz?
    i.e. try downloading the latest kernel from the kernel update screen in your fog gui and giving it a name like bzImage5 and then set that case sensitive name as the kernel on the fog host in question and see if it makes a difference.

    Also, have you checked in the fog web task manager when it is stuck to see if it shows progress there? It’s rare, but I remember once seeing it look like it was stuck but the computer just wasn’t displaying the progress and it was actually working.

  • Moderator

    @austinjt01 Where is it stuck at? Still at the handoff to FOS? I don’t think sysprep is contributing to it working/not working. It could just be bad timing.

  • @george1421 Thanks for the tip - interestingly enough I updated all the lenovo hardware and was able to capture (Pre-Sysprep), now it’s stuck on capturing Post Sysprep.

    FOG version is 1.5.9 that we’re currently running.

  • Moderator

    @austinjt01 Just because its a Lenovo, I would say to ensure your firmware is up to date.

    The issue is the uefi hand off between iPXE and FOS Linux kernel. We have seen this error before on different systems. Its usually tracked to a bug in the firmware on the target computer.

    You can get past/mask the issue by booting FOS Linux off of a usb stick but that approach has some drawbacks so it should be an almost last resort to image this computer step.

    What version of FOG are you using?