Issue deploying image to new Dell Latitude 5410


  • Tried to deploy our existing image to Dell Latitude 5410 laptops. Deploying these to the laptops manually via the “keyboard method” (not registering in the console but just going through the menus right at the laptop).

    Makes it through the menu system of the server, I choose the image and then when it starts deployment, it throws an error “No network interfaces found, your kernel is most probably missing the correct driver!”

    This is odd since it netbooted and I am on the latest version of FOG 1.5.9, not sure if it is a kernel issue or something else. I updated the bios and tried several of the laptops. My Kernel version is 4.19.143 which claims it is the latest in the list. Any suggestions?

    sdfdsfdsf.jpg

  • Moderator

    @rogalskij The FOG developers are expecting the Linux kernel developers will take 5.10.x to LTS status. When they do the FOG developers will make 5.10.x the standard kernel in FOG. ref: https://www.kernel.org/

    FWIW, there was quite a few new drivers added to 5.9.x series (almost as many as was added to 5.5.x), so 5.10.x LTS can’t come fast enough because FOG will start running into that hardware soon.


  • @rogalskij And I answered by own question after reading this post. Very helpful and explains the difference in the kernel versions. Very helpful as always!

    https://forums.fogproject.org/topic/14732/kernel-versions-4-19-143-vs-5-6-18


  • @george1421 I upgraded to the 5.6.18 and it fixed it! What I don’t understand is why the 5.6.18 kernel is lower in the list of kernels if it is the “latest and greatest” kernel. Shouldn’t it be on top instead of the 4.19.145? I am a bit confused by this.

    Also, forgive my ignorance, but what does LTS stand for?

  • Moderator

    @rogalskij said in Issue deploying image to new Dell Latitude 5410:

    My Kernel version is 4.19.143

    There is an upgrade kernel that is not LTS supported that has the drivers for 2019 and 2020 computers. Upgrade your kernel to 5.6.18 from FOG Configuration -> Kernel Download both the 32 bit and 64 bit kernels.

299
Online

8.5k
Users

15.3k
Topics

143.3k
Posts