Mounting issue after FOG update



  • Hi all,

    Please excuse me if my english is not perfect …

    I have update my FOG Server (Ubuntu) 1.5.5.3 to 1.5.7, all seems to go well except when i try to download image on a host i have a mount error

    P91114-094205.jpg

    I have test many things i seen on many topics of this forum like this one https://forums.fogproject.org/topic/9823/mounting-images-dev-on-images-failed-permissions-denied :

    "
    Wayne Workman Mar 30, 2017, 3:41 AM

    Make sure NFS is running with:
    systemctl status nfs-server
    Set the ownership of the images directory to user fog and group root like this:
    chown -R fog:root /images
    Then try again.
    Also, see what this says:
    showmount -e

    "
    Also check the .mntcheck files

    Before upgrade the user in fogsettings and GUI was Fog, upgrade changed it in Fogproject then i changed it again in Fog but got the same error again.

    My server has a separated disk for images but seems ok because the mounting looks good in fstab, and Fog server recognize images and space on “Storage Node disk Usage” in dashboard.

    The problem is i think localise in this part of the error message "storage=10.149.20.64:/media/type=down but can’t say why appear.

    Regards


  • Moderator

    @LittleTux

    How i can pass this post on Solved ?

    Done. Glad it worked



  • @Quazz Thanks a lot, this command actually save my day/week :).

    So update changed my exports file configuration and change the fog user but all is good now.

    How i can pass this post on Solved ?

    Have a good day all, regards.


  • Moderator

    @LittleTux After changing /etc/exports you have to run exportfs -ra so that they actually get ‘exported’



  • Hi,

    Thanks a lot for your answsers, i will try your advices and come back soon.

    Edit : Just tried to modify my /etc/exports file but got the same error again. But i go back to “before update state” why my snapshot and see that before update values in /etc/exports was /media/administrateur/images and /media/administrateur/images/dev like you say @Sebastian-Roth.

    That means that update to 1.5.7 modify my configuration in some ways in this files but not only because if i change it after update it not works.

    Have a good day.


  • Moderator

    @LittleTux There are a few ways to go about this. One method is like the tutorial you found about adding a second (logical) storage node to the FOG server. This method has its good and bad sides. On the good side its pretty easy to implement as long as you follow all of the steps. On the bad side now you have to decide when you create the image definition which disk you want to store the image on.

    One alternative would be to mount /dev/sdb1 on /images. That would make your /images directory 1,2TiB in size. (there are a few steps that need to happen to make this configuration, but no changes are needed in FOG).

    The second alternative is to mount /dev/sdb1 below the /images directory. Like /images/administrateur When you create the image definition you again have to decide to put the images in /images or /images/administrateur directory one is on /dev/sda and the other is on /dev/sdb.

    In my opinion alternative #1 is the best option because it has the least impact on FOG and its settings. If you need to expand the VM disk beyond 1,2TiB you can do that pretty easy as long as /dev/sdb1 is a normal partition.


  • Senior Developer

    @LittleTux You need to manually edit your /etc/exports file to match the images location you use (/media/administrateur/images



  • Well i follow a tutorial on the forum to add a another disk on my Vm for all the images because i have many to manage in the school network i handle. So all the images is on this disk.

    That’s the results of commands

    P91115-091202.jpg

    So /dev/sdb is the images disks and it is mount on /media/administrateur/images, that’s the way it’s configured in the storage node in the GUI and before the update to 1.5.7 it worked good.

    In the .fogsettings the “storageLocation” was /images before the update so i let it. Update changes fogproject si i move it to fog in this file.

    I have a snapshot before the update so ichecked many things on files and GUI before and after update and tried to configure same things on same place but i d’ont know i must forget a thing …

    Regards.


  • Moderator

    Well I see a few things that are wrong or just make me scratch my head.

    I don’t understand this path:
    /media/administrateur/images

    The default FOG storage location is /images

    So I need the output of the following commands

    lsblk
    df -h
    showmount -e 127.0.0.1

    Lets see the output of those commands to decide what to do next.


Log in to reply
 

287
Online

7.4k
Users

14.5k
Topics

136.5k
Posts