Mounting /images/dev on /images failed - permissions denied



  • Server
    • FOG Version: 1.4.0-RC-1
    • OS: CentOS
      SVN Revision: 6069
    Client
    • Service Version:
    • OS:
    Description

    I had my FOG server set up for over 2 years now. So this is not a new nor from scratch installation. I started having this issue after going with latest trunk. Another thing: I suck at linux. Big time. I do a lot of monkey-see-monkey-do stuff. While I agree this is not the best method, I managed to run and enjoy FOG for years. I should have known better than trying to upgrade it. To clarify, the server seems to be K, just cannot capture as I get the "could not mount images folder (/bin/fog.upload) error message. See screenshot below.

    I also came across another thread similar to the error message I ran into (https://forums.fogproject.org/topic/9677/could-not-mount-images-folder-bin-fog-upload/18). I applied the CHMOD 777 command for the images folder. I also checked the NFS services status. I’m not sure what else I need to do. Or what I should provide here as useful information.

    0_1490829666417_fog_error.png



  • Tom, Wayne and George, THANK YOU!!!

    It’s all good now. And I learned a lot. And archiving this on my end with my notes. Until next time.

    I apologize for bugging so much… :(


  • Senior Developer

    @lmorel12 It’s all good.

    For future then, edit your /opt/fog/.fogsettings file.

    If I had to guess, storageLocation='/images' currently.

    Change it to read:
    storageLocation='/home/fog/images'

    If I had to guess, however, another way to prevent issues going forward would be to make a soft link to /images pointing at /home/fog/images. Of course only do this if you know the files are ONLY on /home/fog/images.

    I’d go with my first suggestion just to be fully safe.



  • @george1421 I upgraded to trunk. Went through the process with default settings. If it was clearly displayed that the path changed on me and I missed it, my fault. But I definitely did NOT change the path myself.

    Again, my original configuration/installation might have something to do with it and years later those “leftovers” affected the upgrade to trunk setup? I really don’t know enough.


  • Moderator

    @lmorel12 said in Mounting /images/dev on /images failed - permissions denied:

    I added the /home/fog/images and guess what? It worked!

    Just for clarity, how/why did the images folder get changed to /home/fog/images since /images is the default. Was this an intentional change? If it was then when you ran the installer, you should have told the installer the new location of the images and it would have setup everything correctly for you.

    The reason why I ask is this is the third post in about a week with the same warning error in your OP. If this is something wrong in the docs we need to get them updated. But now I know where to look when this error appears.


  • Senior Developer

    @lmorel12 “No valid data” just means that it hasn’t been captured since that field was added. this is probably an “older” image if you will?



  • OK, so everything looked ok, process wise. I can see it’s doing the capture as usual, took around 10min for 17.17GB. But I also see “No valid data”.

    0_1490893548531_fog_error_4.png



  • @Tom-Elliott I added the /home/fog in front of /images and guess what? It worked!

    I am embarrassed. Beyond embarrassed. But I can tell you I have NOT been in there and touch any of this. I will follow blindly tutorials and wiki without really knowing what it actually does concept wise, but definitely did NOT touch those settings under Storage Management.

    Did upgrade to trunk affect this somehow? I wouldn’t blame anyone for concluding that I need to put that box of matches down and go back to my Legos.



  • @Tom-Elliott Sorry, but what do you mean by “that you keep blocking”? I don’t believe I have firewall up. I ran the following command systemctl status firewalld and it showed as “inactive (dead)”. I made a point to turn it off when I first installed FOG.

    For selinux, are you asking about permissive vs enforcing? When I set up the server, I followed a wiki to do this because I wanted to run FOG on CentOS. Was I supposed to go through some of those steps again after upgrading to trunk? I got this “inactive (dead)” when I submitted the systemctl status selinux command.

    This is what I see under Storage Management settings. Is that what you are asking?

    0_1490891783026_fog_error_3.png


  • Senior Developer

    @lmorel12 Is firewall enabled?
    Is selinux enabled?
    Is the IP (that you keep blocking) the same as what’s expected from the server?

    Seeing as it appears /home/fog/images/dev is being used, what’s defined for the storage location field in the GUI? Is it also /home/fog/images or is it still /images?



  • Thanks! I did this (see screenshot) and I still get the same issue.

    I am “worried” and concerned about one thing: I created a user called fog for that CentOS VM. I have been using root for everything though. But I also see /home/fog/images/dev with the “home” part in the path. I can’t remember if I originally set the server under the fog account. And I believe I was running out of space and followed a tutorial years ago to expand and mount the images folder. Like I said I have no idea what I am doing. And I followed tutorials blindly and it worked right away. I then moved on until I tried to go with the trunk route not long ago. I don’t know if any of this is helpful or not.

    0_1490886728226_fog_error_2.png


  • Moderator

    Make sure NFS is running with:
    systemctl status nfs-server
    Set the ownership of the images directory to user fog and group root like this:
    chown -R fog:root /images
    Then try again.
    Also, see what this says:
    showmount -e
    You should see something similar to this:

    Export list for fog-server:
    /images/dev *
    /images     *
    

    Also, you may find this helpful: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_NFS


Log in to reply
 

358
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.