SOLVED Installation error while the "setting up fogproject user"

  • Hi.
    It’s surely nothing but i encounter this error during the installation.
    i retry several times but nothing to do a this point.
    Have i forgotten something before?
    Anyone have an idea? Thanksfog-error-user.png

  • @Sebastian-Roth So good news and bad news. The bad news is that I am running a Ubuntu server. Good news is that the failed update appears to have saved me from problems. At least my server still seems to be functional. My other problem(my problem, not FOG problem it turns out, stupid fast boot), is fixed(crossed fingers) and I’m capturing with my 1.5.5 server right now. Guess I’ll wait to try updating again until 1.5.8 comes out. 🙂


  • Senior Developer

    @flipwalker Are you using Ubuntu server?? Please make sure you say No if asked about removing and re-installing PHP and Apache when upgrading to 1.5.7 on Ubuntu!!! If you hit the problem already see here: and

  • Good evening,

    I’m running into a couple of problems, but the one that pertains here is a similar problem while trying to upgrade from 1.5.5 to 1.5.7(I think, sorry I’m at home right now trying to get some research done before going back to work tomorrow). I haven’t checked the logs yet, but it’s failing at the same point. I’ll check tomorrow to see if my log is the same and let you know. I’m hoping upgrading solves my other problem, if not I’ll post another post about that one later.


  • Senior Developer

    @Mark-krikunov While you are right about the installer checking on the fogproject user an will complain if it was used to login to the system this clearly doesn’t seem to be the case there! Take another look at the last output @dot posted. It says: useradd: Command not found - something very odd I have not seen.

    As we have not heard back yet I can imagine using su - might have done the trick.

  • @fry_p You do have a point there, but that’s usually how I do it and that’s one of the ways I was able to go around the error. It spits an error because there is existing user in a system. And i have upgraded my systems already but i didn’t need to face this kind of error in process but the way i know that deleting fogproject user will fix it, was from where i was trying to fix none running server, i had to reinstall the server and when i tried i was getting same error and all i did was go and delete fogproject and run install again and it would work.

  • Moderator

    @dot @Mark-krikunov I do not believe that if the proper syntax and permissions are used, there should not be a need to delete the fogproject service account. In fact, I myself would highly advise against that. Just think if somehow this didn’t fix the upgrade issue, then you would be left with a paperweight of a FOG Server.

    Please try @Sebastian-Roth 's suggestion. If you are still having trouble after that, please let us know.

  • Okay I looked up on my server and I believe its fogproject user that needs to be deleted, if your installing it i think there will be no problem if you delete this user because the fog install will create him anyway.

  • Hi, i had this problem, can you send a screenshot of all users on machine, you have to delete a certain user that fog server creates on the go but if that user is already created it will through an error.

  • Senior Developer

    @dot Did you try using su -??

  • Hi, the OS is Debian 10.1

  • Senior Developer

    @dot Looks strange that it doesn’t find the command useradd. What I can imagine is that the environment is not properly set when you only use su to switch to root user. Try using su - (I know it looks awkward but it’s the proper usage to tell su to reload environment variables) and run the installer from that shell.

    What kind of Linux OS is this?

  • @Sebastian-Roth Hi Sebastian, and thanks to take for me.
    I join you the kend of the error_logs file. I don’t put the beginning of the file, because all is ok.
    Like you see, there is a problem with adduser command. but necessarilly in fog, because for sure it’s not possible in a debian, ans like we see, the command is there on the system. This install is done on a VM, i’ll try it on a real PC, to see.

  • Senior Developer

    @dot You find the install logs in /home/dot/Téléchargements/fogproject-1.5.7/bin/error_logs/ - one contains only the output you see on screen but the other one should have hints on why things failed in the background. Please post that full log here.

  • Moderator

    @dot Silly question, may I ask what context you are running the installer as? I usually sudo -i before navigating to the directory and running ./

    Could be wrong but it is a place to start along with providing your OS distribution.