Storage Nodes Not Showing Up



  • FOG Ver. – 1.5.6.4
    OS – CentOS Linux release 7.6.1810 (Core)

    I just migrated over from Debian 9.9 on a new FOG server build to CentOS. Everything is up and running except for multicasting. I was getting an error stating “Fog Server not Master Node”. I went through all of the config changes and updated all instances of username and password found in /opt/fog/.fogsettings file. When doing so, I noticed that the Fog Storage Node would not let me change the IP Address or username. It would say it updated but when I refreshed things it was not updating. I tried a different browser and the problem persisted. So I decided to delete the FOG storage node and re-add it. When I re-added it, the storage node never appeared in the list. I have rebooted the server and restarted all services with no luck in getting my storage node back.

    I don’t know if this is the appropriate place to post this or not. Please move this if it is not.

    Thanks!

    Cheers,

    Joe


  • Developer

    In a remote session we figured out that the database schema version was kind of oddly set. Still not sure why that was. Fixed that and applied the last couple of schema changes. That fixed a couple of odd issues including the Storage Node setting changes that can be done now again.



  • @Sebastian-Roth

    Yes I did. It didn’t help any.


  • Developer

    @Joe-Gill In the other topic I suggested you run the database maintenance stuff. Did you do that yet?



  • @Developers

    Any ideas here?

    Thanks!



  • @george1421
    @Tom-Elliott

    Well I removed .fogsettings file and re-ran the installer. This made no difference on the FOG settings. I removed FOG entirely (minus my images). Re-ran the installer and re-migrated my DB over to the new install and my storage node came back. As a test, I tried adding a new storage node (not as a master) and it still would not allow me to add any new storage nodes or make changes to my existing storage node.

    Any suggestions is greatly appreciated!

    Thanks!



  • @george1421

    Thanks George! I’ll give that try and re-post results. I know it has to be something simple. I just can’t wrap my head around it.


  • Moderator

    @Joe-Gill I don’t know if I have an answer for you on this one. I can tell you that only a full normal mode fog server in a storage group can be a multicaster. If you are running a mix mode where an other device other than a real fog server (with the dabase) is marked as a master node in a storage group, multicasting will not work. Also that ethernet adapter logical name must be defined for that master storage node.

    I’m not sure about what password you are changing or IP addresses. But as a test on one of these storage nodes rename the .fogsettings file to something else then rerun the installer. The installer will forget everything about the last install and ask you the questions over again, just reset that storage node as a new storage node pointing to your newly migrated master FOG server. That should be easier then messing with user ids and password on each storage node.


Log in to reply
 

423
Online

6.2k
Users

13.6k
Topics

128.2k
Posts