Not joining domain after imaging



  • Hey everyone,

    After imaging a machine with Win10, the FOG client does not automatically join the domain. The FOG service is already running after imaging. I tried clearing and inputting the AD info, and using the debugger after seeing this post* , but neither worked. The dump shows the correct user/password.

    I’m not sure what else to do. Does anyone have advice?


  • Developer

    @BenR Don’t know from the top of my head right now as I have not coded the fog client. Could be registry setting. Probably easiest way is to purge and re-install the FOG client on that machine. Sorry but that’s the quick solution.



  • @Sebastian-Roth Oh wow. I can’t believe I miss that. We changed our servers IP address, seems like I missed updating a field somewhere…

    What files/settings need to be updated?


  • Developer

    @BenR Well the log seems pretty clear, the client cannot contact the FOG server. Make sure the IP mentioned in the logs is correct and there is no firewall preventing the communication.



  • @Sebastian-Roth Here you go.

     10/11/2018 3:17 PM Middleware::Communication ERROR: Could not contact FOG server
     10/11/2018 3:17 PM Middleware::Communication ERROR: Unable to connect to the remote server
     10/11/2018 3:17 PM Middleware::Response Success
     10/11/2018 3:17 PM Service ERROR: Invalid promptTime, using default
     10/11/2018 3:17 PM Middleware::Communication URL: http://129.82.31.98/fog/management/index.php?sub=requestClientInfo&mac=F0:92:1C:F0:E7:12&newService&json
     10/11/2018 3:17 PM Middleware::Communication ERROR: Could not contact FOG server
     10/11/2018 3:17 PM Middleware::Communication ERROR: Unable to connect to the remote server
     10/11/2018 3:17 PM Middleware::Response Success
     10/11/2018 3:17 PM Middleware::Communication URL: http://129.82.31.98/fog/service/getversion.php?clientver&newService&json
     10/11/2018 3:18 PM Service ERROR: Unable to get cycle data
     10/11/2018 3:18 PM Service ERROR: Unable to connect to the remote server
     10/11/2018 3:18 PM Middleware::Response Success
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:18 PM Client-Info Client Version: 0.11.16
     10/11/2018 3:18 PM Client-Info Client OS:      Windows
     10/11/2018 3:18 PM Client-Info Server Version: 
     10/11/2018 3:18 PM Middleware::Response ERROR: Unable to get subsection
     10/11/2018 3:18 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     10/11/2018 3:18 PM Service Sleeping for 60 seconds
     10/11/2018 3:22 PM Main Overriding exception handling
     10/11/2018 3:22 PM Main Bootstrapping Zazzles
     10/11/2018 3:22 PM Controller Initialize
     10/11/2018 3:22 PM Controller Start
    
     10/11/2018 3:22 PM Service Starting service
     10/11/2018 3:22 PM Bus Became bus server
     10/11/2018 3:22 PM Bus Emmiting message on channel: Status
     10/11/2018 3:22 PM Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:22 PM Client-Info Version: 0.11.16
     10/11/2018 3:22 PM Client-Info OS:      Windows
     10/11/2018 3:22 PM Middleware::Authentication Waiting for authentication timeout to pass
     10/11/2018 3:22 PM Middleware::Communication Download: http://129.82.31.98/fog/management/other/ssl/srvpublic.crt
     10/11/2018 3:23 PM Middleware::Communication ERROR: Could not download file
     10/11/2018 3:23 PM Middleware::Communication ERROR: Unable to connect to the remote server
     10/11/2018 3:23 PM Middleware::Authentication ERROR: Could not authenticate
     10/11/2018 3:23 PM Middleware::Authentication ERROR: The system cannot find the file specified.
    
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     10/11/2018 3:23 PM Client-Info Version: 0.11.16
     10/11/2018 3:23 PM Client-Info OS:      Windows
     10/11/2018 3:23 PM Middleware::Authentication Waiting for authentication timeout to pass
    

  • Developer

    @BenR The ERROR: Unable to get subsection is just a subsequent error. We need the full log to be able to help. With full I mean from the last time when the PC booted.



  • @Sebastian-Roth I found a text file called “fog” in that directory, but not anything called “fog.log”

    All the categories except UderTracker have the same text under it.


    --------------------------------HostnameChanger------------------------------

    10/11/2018 2:47 PM Client-Info Client Version: 0.11.16
    10/11/2018 2:47 PM Client-Info Client OS: Windows
    10/11/2018 2:47 PM Client-Info Server Version:
    10/11/2018 2:47 PM Middleware::Response ERROR: Unable to get subsection
    10/11/2018 2:47 PM Middleware::Response ERROR: Object reference not set to an instance of an object.


  • Developer

    @BenR Is fog client software installed on the win 10 machine? Possibly the log is in C:\Program (x86)\fog\fog.log



  • @Wayne-Workman said in Not joining domain after imaging:

    @BenR We need a section from the fog log file to help you. It’s here: C:\fog.log The errors in there are the actual windows errors returned from windows. There will be an error code. If you post a big chunk of the log (including error), I will take that and go look it up here and tell you what’s wrong.

    I couldn’t find fog.log. I installed a vanilla version of Win10, captured the image with FOG, and imaged it again. Is there step I’m missing?



  • @BenR We need a section from the fog log file to help you. It’s here: C:\fog.log The errors in there are the actual windows errors returned from windows. There will be an error code. If you post a big chunk of the log (including error), I will take that and go look it up here and tell you what’s wrong.


 

563
Online

5.4k
Users

12.6k
Topics

118.9k
Posts