Image capture hangs on "Saving original partition table..." Need help with fixparts



  • I ran into the issue of my image capture hanging on “Saving original partition table…” I did the research and found my answer. There is likely remnants of GPT partitions on the disk and I need to boot the host into debug mode and run fixparts.

    And that’s where most of the posts I’ve found while researching this issue ends. “Run fixparts…” So I updated the kernel so that I am able to run fixparts. I run it.

    fixparts /dev/sda
    

    But then I get

    MBR command (? for help):
    

    I hit “?” and I’m presented with a list of choices.

    a     toggle the active/boot flag
    c     recompute all CHS values
    l     set partition as logical
    o     omit partition
    p     print the MBR partition table
    q     quit without saving changes
    r     set partition as primary
    s     sort MBR partitions
    t     change partition type code
    w     write the MBR partition table to disk and exit
    

    I have no idea what I’m supposed to choose and none of the posts I’ve found have mentioned what choice I need to make. They either just say to run fixparts or run fixparts and follow the prompts. I also don’t want to erase any data on the disk and this is an image that I need to capture.


  • Moderator

    @kratkale said in Image capture hangs on "Saving original partition table..." Need help with fixparts:

    sgdisk -z /dev/sdx

    I would have to check, but I believe sgdisk is built into FOS. You could have done a debug deploy/capture and run the same command without needing to setup clonezilla. But its great you have it fixed and can image again.



  • @Zerpie
    I solved a similar problem with clonzilla …


    The second problem was solved with the help of clonzilla:
    Problem of changing from uefi to bios while a system in uefi mode was installed.
    start clonzille
    use the shell
    sgdisk -z /dev/sdx
    in my case
    /dev/nvme0n1


  • Moderator

    @Zerpie FWIW: Downgrade your FOS kernel to 4.15.2 for now until the FOG developers can find out why the newer FOS kernels are having this delay.



  • Looks like I needed to be a little more patient or do just a little more research. I read a post that explained that this is a known issue and it will sometimes get stuck on “Saving original partition table…” but will eventually move past it after about 5 minutes or so. Sure enough, my capture process continued after a little while. Good to know.



  • I’m assuming that since fixparts isn’t spitting out a warning about GPT signatures detected on the disk and offering to fix it, that this isn’t my issue. But then I’m back at square one with the process hanging when on “Saving original partition table” when trying to capture an image. Not sure what else I can try to fix this.



  • @Wayne-Workman I’m running 1.5.4 and it’s a fresh install as of yesterday.



  • @Zerpie What version of fog are you using? I ask because I’m pretty sure late fog versions always run fixparts for you, automatically.


Log in to reply
 

400
Online

6.1k
Users

13.4k
Topics

126.3k
Posts