SnapinPack SnapinClient ERROR: 1 is not a supported code page. Parameter name: codepage



  • FOG Version 1.5.0
    FOG Client Version 0.11.15

    Snapinpack with Visio 2016 or Office 2016
    Target systems: Win7 and Win10
    Win7 works
    Win10 fails with error.

    Hi
    as mentioned in title I have problems deploying SnapinPacks on Windows 10.
    Here the full log entry on from the client. (removed mac Addresses)

    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
    15/03/2018 15:23 Client-Info Client Version: 0.11.15
     15/03/2018 15:23 Client-Info Client OS:      Windows
     15/03/2018 15:23 Client-Info Server Version: 1.5.0
     15/03/2018 15:23 Middleware::Response Success
     15/03/2018 15:23 SnapinClient Running snapin Visio_2016_x32
     15/03/2018 15:23 Middleware::Communication Download: http://fogserver/fog/service/snapins.file.php?mac=xx&taskid=87
     15/03/2018 15:23 SnapinClient C:\Program Files (x86)\FOG\tmp\Visio2016Pro_x32_en.zip
     15/03/2018 15:23 SnapinClient Processing SnapinPack Visio2016Pro_x32_en.zip
     15/03/2018 15:23 SnapinClient Extracting SnapinPack
     15/03/2018 15:23 SnapinClient ERROR: 1 is not a supported code page.
    Parameter name: codepage
     15/03/2018 15:23 Middleware::Communication URL: http://fogserver/fog/service/snapins.checkin.php?taskid=87&exitcode=-1&mac=xx&newService&json
    ------------------------------------------------------------------------------
    

    My target machines have these specs:
    Edition: Windows 10 Enterprise
    Version/Build: 1709
    Location: Switzerland
    Language: English (United States)
    Keyboard layout: Swiss German

    Searching the web I found this:
    https://github.com/chef/chef-dk/issues/1290#issuecomment-323185687

    Is it the same issue?

    Thanks for your help.
    Kind Regards
    Eduardo



  • Hi

    @Joe-Schmitt sorry for my delay too.
    Thank you for your option to check it remote.
    I was perparing some VMs so that you could access it vor remote and I have found out that with same Win10 Image, but Version 1803 that just came out, I can install Snapin Packs again.

    And my Version of Fog is still the same.
    I will still lookout for it, but I would say it is an issue with either 1709 or something specific with Windows internally.

    From my perspective we can close this issue.


  • Senior Developer

    @emc sorry for the delay, feel free to bump the thread or send me a PM if it seems I’ve lost track of it. Would I be able to remote into one of the problematic machines? Send me a PM if this is an option and we can work out a time that works for both of us.



  • Hi,

    I did more testing. I changed Language to German/Switzerland, but it didn’t help.
    Neither creating the zip on the target machine.

    Same error as before.

    But with older Win10 Versions I have no issues.

    kind regards
    Eduardo



  • @Joe-Schmitt Answer part 1/2:
    I created the zip with 7-zip 16.02 and 7-zip18.01, as well as with native Windows 7 native zip.
    None of them where successful.

    Interestingly enough I installed/deployed the SnapinPack without errors on another Windows 10 Version 1709 machine.
    Difference is the combination of Language and input type. This new one has Language German and input type Swiss German.

    Sharable Zip for testing will come in my next answer. I also want to test if I find more machines that fail this peculiar case.

    Edit: 2018/03/20
    Answer part 2/2
    A minimalistic snapinpack. Just a batch that should redirect echo to %temp%
    https://earth.dinterface.ch/index.php/s/aEAB4KiwrMOMPWC/download
    fogproject

    It fails with same error on machines with Language Englisch US, Keyboard Swiss German.
    But I could run it on a system with Language German, Keyboard Swiss German. (Win10 Version is not the same)



  • @Joe-Schmitt I have to check tomorrow. As my target Win10 with 1709 is not online at the moment.
    On another with 1703 I could install the SnapinPack.
    If testing and stuff doesn’t bring good results, I’ll try to create a smaller/sharable SnapinPack.


  • Senior Developer

    @emc Awesome, thank you!

    Another test that would be helpful would be to make a smaller / sharable SnapinPack (e.g. one that just has a simple script in it and that you can freely share with me without any concerns). If this problem persists across all Snapin Packs, and not just the Visio one, would I be able to get a copy of the smaller / sharable zip file?



  • @Joe-Schmitt it was 7-zip on a Windows 7 machine.
    If it helps I’ll test it with native Windows. Keep you posted.


  • Senior Developer

    [Moderation Note: Moving topic to Bug Reports]


  • Senior Developer

    @emc this appears to be an issue with how the client is extracting the zip file with extended ASCII code pages.

    How did you make the zip? Was it with 7-zip, the native Windows method, or another application?



  • @george1421 I updated my original Post with all the information.
    Thank you for forwarding / looking into it!


  • Moderator

    OK we may need to get the developers to look at this.

    Can you provide this additional information.

    1. Win10 version (i.e. 1703)
    2. Win10 edition (i.e. edu)
    3. Windows Location (country/region) setting (i.e. us)
    4. Keyboard Language (i.e us)


  • thanks for your request.

    Yes I did it manually and it works. Unzip it without any issues.
    Then cmd as admin-> setup.exe /config config.xml.
    Background process is started and after some time Visio is installed.

    And as mentioned for Windows 7 targets the SnapinPack works.


  • Moderator

    If you copy the snapin pack to the target computer, unzip it and run the installer command locally does it install correctly? I’m interested in seeing if the issue is with the application (like an install time switch is missing) vs the FOG snapin system.


 

557
Online

5.4k
Users

12.6k
Topics

118.8k
Posts