Dorked Snapin Pack Argument & Can't Delete Snapin On v1.5.0 RC-9



  • I normally create snapins that are exes, but I created one Snapin Pack and found the system has dorked the argument string some where along the way.

    The argument for this snapin pack was:
    /c “[FOG_SNAPIN_PATH]\copyFOGExe.cmd”

    Here’s the screenshot of the present value:
    0_1507777835587_eb1a6384-ed47-4627-9158-2bfc75249639-image.png

    I attempted to delete this snapin and re-create it but I cannot delete it. When I hit delete, nothing happens. After waiting a long time and listing all snapins, it’s still there.

    Any ideas?

    This could be a generic issue or related to the RC.

    Thanks,

    Jim


  • Developer

    @Jim-Graczyk Do you still need assistance on deleting that snapin from the DB? When editing the snapin in the web UI you can see it’s ID in the URL. Note that down and open a terminal on your FOG server:

    shell> mysql -u root -p
    ...
    mysql> use fog;
    mysql> DELETE FROM snapinAssoc WHERE saSnapinID = x;
    mysql> DELETE FROM snapins WHERE sID = x;
    mysql> quit
    shell>
    

    Replace “x” in ... = x; with the ID you noted down earlier.


  • Moderator

    @jim-graczyk said in Dorked Snapin Pack Argument & Can't Delete Snapin On v1.5.0 RC-9:

    If it’s not too much trouble, could someone give me a way to delete this snapin in SQL.

    I can when I’m home tonight.



  • Hi,

    why not update to working branch? Like tom said the problem should be solved then.
    If you normally don’t want to stick with working-branch you can wait for the next RC release and switch then back to dev-branch while you used working-branch in the meantime.

    Regards X23



  • @tom-elliott

    Tom,

    I have no idea if it’s related to the version I’m running. I have 2 instances off FOG, so not a lot to go on. I can say that the same Snapin definition in my Lab remains as it was entered. The Lab is on a recent working branch. For this production version, we’re sticking with RCs. So it could be a non-issue.

    We’ll wait for RC10 release to update productionn and see what happens. If it’s not too much trouble, could someone give me a way to delete this snapin in SQL. I have it disassociated from all replication, hosts, storage groups, etc - anything I can do from the UI. If not, it’s just one snapin so NBD. I don’t think I can recreate it and expect the new one to survive any better than the original. It’s a snapin used only to make images, so it’s seldom used.

    Consider this Solved and we’ll take it up later, if need be.

    Thanks,
    JIm


  • Senior Developer

    I’m unable to replicate the problem on working (version 63). Is this specific to 1.5.0-RC-9 as stated in the Version? If I remember correctly, the ajax portion was broken a little bit and has since been addressed.


Log in to reply
 

494
Online

39192
Users

10844
Topics

103205
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.