Problems after changing fog server IP



  • Hello, we recently transitioned our VM’s to a more standardized IP scheme and now im having a couple lingering issues with fog. I changed the IP from the old one to the new one in every place I found, read all the articles on it, then re-ran the fog setup. My web UI is working fine, I can PXE and get to the main fog splash screen, I can even register new hosts just fine. The issue comes when I try to deploy an image to a computer, I get the error:
    "Could not mount images folder (/bin/fog.download)
    Args Passed:
    Because: Mount: Mounting <OLD IP ADDRESS>:/images on /images failed: COnnection timed out

    Kernel variables and setting: <BUNCH OF STUFF, INCLUDING THE OLD WRONG IP> (storageip, ftp, and storage variables all set to the wrong IP)

    Ive been reading a bunch of posts online trying to narrow this down, but ive got 50 computers to image by the end of the day so its kinda getting to be crunch time. Any help you can provide is appreciated.


  • Moderator

    Just adding here that the updateIP tool does all of this stuff for you automatically… :-)

    All you gotta do is update your OS’s IP address according to the distribution documentation you’re using - then run the tool. The rest is magic.


  • Testers

    @motherfogger said in Problems after changing fog server IP:

    Changing the IP now, im assuming itll be all set after that. If you dont hear from me, assume im all set and wearing a dunce cap…

    No dunce cap required, I’m pretty sure everyone feels that way when they first start learning linux and the Fog system too. The more you learn it the more it all makes perfect clear sense.



  • @jj-fullmer This is the only option I see about storage nodes in the webUI:
    alt text

    As far as testing the node goes, im confident everything is working, the error specifically (and thankfully) states its trying to contact the image repository at the old .131 address, id take a picture of it if I could, but my phones camera suffered an untimely death due to a freak washing machine accident…

    Most of the exact error im receiving is in my OP, I just need to know where the variables storageip, ftp, and storage are stored. I havent come across them in any of the system files ive looked through.

    Not going to lie, I just found out what ^f means, apparently ^ is somehow supposed to mean control, which apparently moves vi foward one page…ive been working out of the first page of everything apparently :(

    Just checked my /var/www/fog/lib/fog/Config.class.php settings, all are pointed to the new IP. Im going back now to check my .fogsettings file

    EDIT - Ya maybe if I had any clue at all what I was doing I could have figured this out sooner. Definitely not a linux guy…I just found the exact field I missed, I didnt know there was a whole storage managment section of the webUI, but if I had payed attention I would have seen this in the article I read about 500 times:
    https://wiki.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address
    "Update the IP address for the storage node on the FOG system where you changed the IP address Web Interface -> Storage Management"

    Changing the IP now, im assuming itll be all set after that. If you dont hear from me, assume im all set and wearing a dunce cap…


  • Testers

    @motherfogger Storage node settings are in the webgui. You’ll want to click through to the default/fog storage node settings to see the ip address. I believe that’s were it would be pulling the ip address from during capture, so that’s the most likely place.

    As for using that script, if you don’t have another linux server, it’s not much of a test. You would just be running it in the shell/command line/terminal. Copy and pasting the commands like the command prompt. If you happen to have Windows 10 Enterprise (or 8.1 too) you can enable the “client for nfs” feature in windows and attempt to mount the images share in windows like you would any other share (win+r \fogserverip\images) There are probably third party tools if you don’t have access to a enterprise license. I believe it’s in the education version of windows 10 as well, but I am not certain as I don’t have one of those.



  • Thanks for the replies.

    @george1421 I followed this guide: https://wiki.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address
    and took bits and pieces from other threads to fill in the blanks. I believe I have performed all the steps you suggested, I can confirm with 100% certainty that all the IP addresses in the webUI are pointed to the new one, as well as in my .fogsettings file (I modified it last week when we changed IP’s)alt text

    The new IP should be 10.10.10.22, and the old one ends in a .131. Ive checked a lot of the config files already, and I used this guide to verify that the exports file was fine:
    https://wiki.fogproject.org/wiki/index.php?title=Change_NFS_location
    I ran a exportfs -a afterwards, even though the settings were fine in the file. I also rebooted the server for good measure.

    I dont have any other linux servers, and I have seen that script before, but to be honest once I step out of my nice safe windows environments im mostly lost. I do not know how to transfer that script to the server to run it, a painfully simple process for sure, but without a nice fancy GUI it might as well be in chinese and upside down. If someone could walk me through the steps of actually making that file run on my server I would really appreciate it, or if there are any other places to check that I missed let me know too. When I changed the IP’s last week I did re-run the installer, so whatever settings that changes “should” be correct.

    EDIT - @george1421 After re-re-reading your post, can you cllarify step 2 please? Should the storage node definition be part of the web UI, or is that located somwhere else?


  • Testers

    From your description, I would bet the spot you missed is in the storage configuration.
    But I would suggest double checking all the places @george1421 mentioned as well and give @Wayne-Workman 's script a try

    If you have other linux servers on the network you can debug this by making sure you can mount the nfs images share

    something like this

    mkdir /mnt/fogImages
    newFogIp=192.168.1.123 #whatever the new ip is
    mount $newFogIp:/images /mnt/fogImages
    ls -l /mnt/fogImages #should display the contents of your images folder
    

  • Moderator


  • Moderator

    OK changing your fog server IP address is never a good thing after FOG is installed. But I think we can get you going again.

    1. You need to update the IP address in the web ui, go to fog settings. I think its in the tftp section. The easiest is to expand all sections and then search for the old IP address. Once the fog settings are correct then off to the next step.
    2. Go into the storage node definition for this fog server. Change the IP address listed there to your new IP address.
    3. Now off to the linux command prompt on the fog server.
    4. You need to edit the following configuration file. /opt/fog/.fogsettings (hint: its hidden). Replace the old IP address with the new IP address and save.
    5. Last step, rerun the fog installer script (installfog.sh) to fix the remaining bits.
    6. Reboot your fog server for good measure.

    That should be it, you should be back in business.


Log in to reply
 

995
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.