Boot File Testing for SR


  • Testers

    svn5901_ipxe: hang on init.xz


  • Testers

    svn5836_ipxe: hang on init.xz


  • Testers

    svn5835_ipxe: no hang on init.xz


  • Testers

    @psycholiquid and DHCP failed (This doesnt have the secondary NIC plugged in


  • Testers

    EFI 01 Timer Test:

    0_1505315163733_952fd860-fd72-4937-83ba-2712f1222e8c-image.png

    0_1505315175093_df5afcb0-2f2d-4a41-87f9-a71420fba830-image.png

    0_1505315184266_5c933b3a-7131-4ce7-900b-9b3a1931f920-image.png

    0_1505315194063_02a09401-969f-423a-ba5b-fc721b2f827c-image.png

    0_1505315275515_3d7b15ac-1565-4a5c-89af-98f4030ca0d1-image.png

    but I have the hsa_usb_nic=1 still on


  • Testers

    EFI timer test:

    0_1505314416520_b4388933-144f-4fa5-99c5-ad21334e90c0-image.png


  • Testers

    Surface Test with USB NIC and using file 04_ipxe.efi I get the following:

    It will get to the menu without issue. I am choosing the last option to Compatibility to see it hit the init file and the following happens:

    Works without issue, eth0 doesn’t pick up on DHCP but secondary USB NIC does and works to image or register hosts.


  • Testers

    Surface Test with no USB NIC and using file 05_ipxe.efi I get the following:

    It will get to the menu without issue. I am choosing the last option to Compatibility to see it hit the init file and the following happens:

    Never gets past init.xz


  • Testers

    @sebastian-roth said in Microsoft Surface Pro 4:

    @Psycholiquid If you are keen enough we might even figure out that issue as well and get rid of that need to unplug/replug USB NICs as well. But let’s focus on the iPXE issue first. Thanks for testing!

    No problem Its what I do LOL


  • Testers

    @sebastian-roth said in Microsoft Surface Pro 4:

    @Psycholiquid Please add the has_usb_nic=1 parameter (either in the host’s settings if it is registered already or in the general settings page (you’d see this for all hosts then). On boot it should prompt you to remove and replug the USB NIC. Then DHCP should work.

    By the way: Which version of FOG do you have? Tom has added the feature to recognize clients by sysuuid rather than MAC address. See here. AFAIK this should work in FOG 1.4.4

    Surface Test 1 with no USB NIC and using file 04_ipxe.efi I get the following:

    It will get to the menu without issue. I am choosing the last option to Compatibility to see it hit the init file and the following happens:

    0_1505313114468_cf4a0bed-0402-4168-a3ce-fa3ab41e1ad6-image.png

    0_1505313131235_26c59c57-c15e-41c8-a776-d4bd0bce3448-image.png

    So all in all it works but again you have to run arond unplugging and replugging docks or USB NICs (Docks in the case of Surfaces/


  • Developer

    @Psycholiquid If you are keen enough we might even figure out that issue as well and get rid of that need to unplug/replug USB NICs as well. But let’s focus on the iPXE issue first. Thanks for testing!



  • @sebastian-roth said in Microsoft Surface Pro 4:

    @Psycholiquid Please add the has_usb_nic=1 parameter (either in the host’s settings if it is registered already or in the general settings page (you’d see this for all hosts then). On boot it should prompt you to remove and replug the USB NIC. Then DHCP should work.

    By the way: Which version of FOG do you have? Tom has added the feature to recognize clients by sysuuid rather than MAC address. See here. AFAIK this should work in FOG 1.4.4

    I did not know about the has_usb_nic parameter. That’s helpful for me. Thanks. I was just timing it and unplug/plugging in.


  • Testers

    @sebastian-roth said in Microsoft Surface Pro 4:

    @Psycholiquid Please add the has_usb_nic=1 parameter (either in the host’s settings if it is registered already or in the general settings page (you’d see this for all hosts then). On boot it should prompt you to remove and replug the USB NIC. Then DHCP should work.

    By the way: Which version of FOG do you have? Tom has added the feature to recognize clients by sysuuid rather than MAC address. See here. AFAIK this should work in FOG 1.4.4

    I am on 1.5.0 RC7. Trying the has_usb_nic=1 now that has worked in the past but I opted for the USB nic that just works in using in a lab environment it is a pain to go around unplugging and plugging back in. But I will do it for you anyway and come back with results.


  • Developer

    @Psycholiquid Please add the has_usb_nic=1 parameter (either in the host’s settings if it is registered already or in the general settings page (you’d see this for all hosts then). On boot it should prompt you to remove and replug the USB NIC. Then DHCP should work.

    By the way: Which version of FOG do you have? Tom has added the feature to recognize clients by sysuuid rather than MAC address. See here. AFAIK this should work in FOG 1.4.4


  • Testers

    Surface Test 2 with now USB NIC and using file 05_ipxe.efi I get the following:

    It will get to the menu without issue. I am choosing the last option to Compatibility to see it hit the init file and the following happens:

    0_1505312396461_010468e2-729a-481e-802a-9f21e9653007-image.png ![alt text](image url)


  • Testers

    0_1505312230086_5aa48df3-c953-4d0e-be33-0d4ec319f32e-image.png


  • Testers

    @sebastian-roth said in Microsoft Surface Pro 4:

    Thanks heaps for reporting back on this…

    @psycholiquid said in Microsoft Surface Pro 4:

    I am using ipxe7156.efi

    Yes we still have those old binaries around as we couldn’t figure out what’s wrong with the newer iPXE versions. I beg you to help us finding what’s wrong and finally get rid of those ugly extra binaries!!

    Please take 15 minutes (I am pretty sure it shouldn’t take any longer) to test a couple of binaries for us as we devs don’t have those devices to test with. Find the files to test here. Please try out 04_ipxe.efi (should work) and 05_ipxe.efi (should have an issue, hanging on init.xz) and report back. Then if you have another 20 minutes, please also test the binaries called svnXXXX_ipxe.efi and let me know which ones work and which don’t.

    Surface Test 1 with now USB NIC and using file 04_ipxe.efi I get hte follwing:

    It will get to the menu without issue. I am choosing the last option to Compatibility to see it hit the init file and the following happens:

    0_1505312070327_351f10e1-2479-49d0-9ddd-bc92d3ffbf0d-image.png


  • Developer

    @Psycholiquid Thanks for the quick reply. I am not absolutely sure what we are after here. It’s been reported that surface devices had issues PXE booting and we kept telling people that they could make it work by using the ipxe7156.efi binary. But we never actually asked everyone about the NICs used. At one point I had the impression that this was mostly an issue with Realtek USB NICs but we don’t have enough evidence to proof this. So you might try out things with the dock only and then with the USB NIC only.

    Although it works for you switching between dock (for PXE boot) and USB NIC (for actual imaging) I think this is definitely not great. Let’s hope we can gather some more information and maybe make this work nicely.


  • Testers

    @sebastian-roth said in Microsoft Surface Pro 4:

    Thanks heaps for reporting back on this…

    @psycholiquid said in Microsoft Surface Pro 4:

    I am using ipxe7156.efi

    Yes we still have those old binaries around as we couldn’t figure out what’s wrong with the newer iPXE versions. I beg you to help us finding what’s wrong and finally get rid of those ugly extra binaries!!

    Please take 15 minutes (I am pretty sure it shouldn’t take any longer) to test a couple of binaries for as as we devs don’t have those devices to test with. Find the files to test here. Please try out 04_ipxe.efi (should work) and 05_ipxe.efi (should have an issue, hanging on init.xz) and report back. Then if you have another 20 minutes, please also test the binaries called svnXXXX_ipxe.efi and let me know which ones work and which don’t.

    Yeah I can do that for ya, I have all sorts of fun toys to play with here. I am working on Vendor classes today so there is alot of rebooting going on. I will report back with results.

    So the question is do you want me to try it with or without the extra USB NIC?


Log in to reply
 

452
Online

6.2k
Users

13.6k
Topics

128.0k
Posts