"Seems like you are trying to restore to an empty disk" issue



  • Server
    • FOG Version: 1.3.0 rc-5
    • OS: Ubuntu 14.04
    Description

    I am trying to push a Windows 10 image to an HP Compaq 8200 Elite Small Form Factor PC. We bought ten of these. I imaged nine of them without any issues, same image for all of them.

    The final machine keeps giving me a “Seems like you are trying to restore to an empty disk. Be aware this will most probably cause trouble”. I have tried different HDDs, MBR/GPT, with a primary partition, and without a primary partition. Can anyone suggest something to try? Thanks.

    0_1498766496718_IMG_1571.JPG


  • Testers

    Two other things to check are the bios versions identical, and is secure boot on or off.


  • Senior Developer

    So the HDD moved around fails continuously? Maybe firmware on the one machine that’s just “not” working?

    This still doesn’t feel/sound like it’s something FOG’s doing.



  • @Tom-Elliott

    I checked. It was in IDE mode. I switched it to ahci with no success.


  • Senior Developer

    @PageTown Did you check that “10th” machine and as the BIOS is probably presenting the disk on that machine in RAID mode.


  • Moderator

    @PageTown I’ve seen bad sectors on a hard drive cause similar issues with ghost.

    But looking at your install version, I might recommend that you update to the latest version of FOG. You are on an RC release of FOG 1.3.0. There was several important fixes with hard drive partitioning that were introduced in FOG 1.4.1 and then it looks like a solid fix was added to FOG 1.4.4 for single disk resizing issue under certain conditions (granted you didn’t get this far yet with these troubled hard drives). I feel that updating to the latest release is still in your best interest.



  • I pulled the HDD out of one of the nine machines that fogged successfully and put it into the machine that didn’t and it booted up perfectly. I tried the HDD that was in the problem machine into one of the good ones and got the same error. I tried two other HDDs and got the same error as well. This is weird. All are Seagate HDD and pass diagnostics as “good”. I’m going to DBAN these drives, delete the host and try again.


  • Senior Developer

    I feel I should add that while it’s possible it’s a hardware issue, you might check that system is presenting the HDD as sata/ahci as opposed to raid.


  • Moderator

    @PageTown said in "Seems like you are trying to restore to an empty disk" issue:

    We bought ten of these. I imaged nine of them without any issues, same image for all of them.

    Those are the key words here. You have 10 identical boxes, and you attempted to apply the same image to all 10.

    9 succeeded.

    If your statement is absolutely, without conditions, true - then something must be wrong with the 10th box.

    Run disk diagnostics on the 10th box, see what those results say. Trade HDDs between the 10th box and another from that batch, see if the HDD will image in the other machine or not. See if the traded HDD will re-image in the 10th machine (if that makes sense).

    I could be wrong of course, but it sounds like something is just wrong with that 10th box’s disk. You just have to do whatever troubleshooting to figure this out, and find the faulty component. In this case, I really doubt FOG is at fault here because it worked on the first 9 without issue.


Log in to reply
 

376
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.