• FOG 1.5.10.1606 Time of captured image shows UTC time not local time

    Unsolved
    10
    0 Votes
    10 Posts
    2k Views
    tiatualizadoT

    @Fog_Newb

    Hi,
    I had the same problem as you, and I solved it this way:
    I updated FOG to the latest version (1.5.10.1655), and configured the time zone I wanted in the graphical interface, in “Fog Configuration > Fog Settings > General Settings > TZ INFO”.
    On the VM where I have the FOG server installed, which is an Ubuntu Server 24.04, I only edited the file “/etc/php/8.3/fpm/php.ini” adding the information: date.timezone = “America/Fortaleza” (this is my local time zone). I added this information just below the explanation about timezone that the file itself brings, as you did and showed here in the images.
    I restarted the VM and the time was finally correct in the FOG records.

    I also followed this topic by @Sebastian-Roth, it helped a lot!
    https://forums.fogproject.org/topic/15434/time-lag-between-the-fog-web-interface-and-the-system-time/2

  • Client hostname change problem

    Unsolved
    1
    0 Votes
    1 Posts
    311 Views
    No one has replied
  • turning on secure boot after windows

    Unsolved
    1
    0 Votes
    1 Posts
    423 Views
    No one has replied
  • how to turn off https support

    Unsolved
    7
    0 Votes
    7 Posts
    2k Views
    R

    @Tom-Elliott is there a way to find out where its failing

    i have the PCAP file if interested?

  • 0 Votes
    1 Posts
    394 Views
    No one has replied
  • images no size on web portal

    Unsolved
    1
    0 Votes
    1 Posts
    305 Views
    No one has replied
  • Fog saving filenames instead images in /images directory

    Unsolved
    8
    0 Votes
    8 Posts
    2k Views
    R

    @marcolefo not yet, i was running 1.5 on centos 7 and now re installed fog 1.5 on alma 9.5, i will let you know if i get the same issue on new OS

  • Windows server 2008 virtual to physical

    Unsolved
    1
    0 Votes
    1 Posts
    328 Views
    No one has replied
  • usb network boot ipv4 network disabled

    Unsolved
    2
    0 Votes
    2 Posts
    481 Views
    R

    any help?

  • fog update fails from 1.5.10 to 1.5.10.1639

    Unsolved
    2
    0 Votes
    2 Posts
    798 Views
    P

    fixed it by installing gcc-aarch64-linux-gnu on ubuntu and running the script again. compilation errors are not logged to the script shown on screen, but to the bin/error_logs/ directory in the extracted archive.
    Update now ran without issues.

  • FOG Storage issues

    Unsolved
    1
    0 Votes
    1 Posts
    312 Views
    No one has replied
  • Mariadb : Incorrect definition of table mysql.column_stats

    Solved
    3
    0 Votes
    3 Posts
    3k Views
    M

    @marcolefo

    Okay nothing to do with FOG 😉

    ALTER TABLE mysql.column_stats MODIFY histogram longblob; ALTER TABLE mysql.column_stats MODIFY hist_type enum('SINGLE_PREC_HB','DOUBLE_PREC_HB','JSON_HB');

    Sorry for the noise

  • updating from stable to working branch but get schema error

    Unsolved
    2
    0 Votes
    2 Posts
    428 Views
    R

    tbh i am running fog on centos 7 so maybe its time to re install the OS to rocky 9.5 or ubuntu 24

    what OS do you recommend?

  • error deploying windows 11

    Unsolved
    19
    0 Votes
    19 Posts
    4k Views
    R

    @Tom-Elliott looks like i have to update my fog to 1.6 instead of 1.5 as i thought i resolved it by updating fog to the latest 1.5 but the error is still there on 1.5, i thought it went at first as when i made my first image it saved as a folder but on my second capture its saving as a file again

  • FOG & iPXE Anywhere - issues from boot menu

    Unsolved
    2
    0 Votes
    2 Posts
    648 Views
    george1421G

    @MichaelPower said in FOG & iPXE Anywhere - issues from boot menu:

    Just wondering if a working bzImage I can use that boots under Secure Boot?

    The issue is exactly that. bzImage is not signed so the uefi firmware will not boot it. That is the root of the issue. You could self sign ipxe and bzImage but then you will need to update the certificates in each computer to include your self signed certificate. Its possible but it is quite a bit of work to get it all setup.

  • FOG API question

    Unsolved
    2
    0 Votes
    2 Posts
    834 Views
    J

    Ok,

    I finally figured this out. I know it’s not the best method, but I prefer this than having the wording “plain text” Here’s what I did in case someone needs to do the same.

    I read that API tokens do not go well as a securestring. Here are some references:
    https://jamesone111.wordpress.com/2020/04/10/transformers-for-powershell-parameters-which-take-secrets/, and https://github.com/Azure/azure-powershell/issues/25533.

    So in order to get past this, I needed to create another variable as show below:

    $testapi1 = [pscredential]::new(“token”,$yourtoken)

    You’re basically adding the pscredential above like you’re going to setup a username, but you put something like “token” or any wording as a placeholder for the username, then put the token in.

    Then after you define the header you do something like this: $testheader.add(fog-user-token’,$testapi1.GetNetworkCredential().password)

    Again it’s not the best method, but I also read a way when you do read-host -aseecurestring and save your api there as a variable, you can dispose that variable so it doesn’t stay in memory.

    $test.disposeof

    If someone has any better ideas, please let me know as I’m always on here learning new things and want to share as well. This basically can be closed out.

  • FOGTaskScheduler 100% CPU

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    M

    So I have deleted the entry with no data

    DELETE FROM powerManagement WHERE pmMin = '' OR pmHour = '';

    The problem is resolved.
    I have backed up the table before 😉

  • Problems with storage nodes in the same system

    Unsolved
    1
    0 Votes
    1 Posts
    286 Views
    No one has replied
  • 0 Votes
    6 Posts
    1k Views
    I

    This can sometimes happen after you have sysprepped an machine and missed the boot menu prompt, entering the Out-of-box-experience. Trying to shutdown the device will leave the dirty bit resulting in the unclean error.

    To avoid having to sysprep again, allow the device to enter OOBE again and hit shift+F10 and enter “oobe\bypassnro” at the resulting command prompt. Once you hit enter, the system will perform a clean reboot, clearing the dirty bit and allowing Fog to capture the filesystem correctly.

    Hopes this helps someone else as some Dell machines are notorious for failing to get an IP from IPV4 PXE boot.

  • 0 Votes
    2 Posts
    903 Views
    I

    are they all in a clean shutdown state before starting?
    do they already have an OS?

54

Online

12.8k

Users

17.7k

Topics

157.2k

Posts