Problems Deploying Image FOG 1.4



  • Server
    • FOG Version: 1.4.0 RC-6
    • OS: Ubuntu 16.04 LTS
    Description

    I am unable to deploy an image to a host the attached picture is what happens was able to deploy no problems before I upgraded from 1.3.0 RC-16

    0_1492542078069_20170418_135125.jpg

    I am using UEFI and the bootfile is ipxe.efi
    I am not having trouble on machines that use undionly.kxe and are legacy booting.
    I checked the images folder and the image is present.




  • Senior Developer

    @jeffj So it’s safe to solve the thread?



  • Okay when creating a new image that was resizable I receive the dirty filesystem 0,0 error.
    rebooted the system and turned fast startup off.
    After doing so I was able to create the image successfully.
    Tried to deploy the newly created image on the smaller HDD and so far so good we are writing the image now.

    Recap for marking the post solved.

    Could not image HDD with known good image was getting a "No image file(s) found that would match the partition(s) to be restored (performRestore)"
    Ran Debug mode to see what partitions were being created on the HDD.
    Checked the partition table on the image on the server.
    Noticed that the image was a MPS(Multiple Partition Single Disk) and HDD in host was smaller than the original used to create the image.
    Disabled Fast booting on the host I need to re-create an image from.
    Re-created an image using SDR (Single Disk Resizable).
    Was then able to deploy the image to the host with the smaller HDD with no problems.


  • Moderator

    @Tom-Elliott said in Problems Deploying Image FOG 1.4:

    Sorry I was driving. Yes your image was captured MPS (Multi-partition Single Disk non resizable).

    Ah that’s what Imgtype mps meant. I just though you hit turbulence and that’s what I got. ;-)


  • Senior Developer

    Sorry I was driving. Yes your image was captured MPS (Multi-partition Single Disk non resizable).

    The original disk was, what appears to me, 500GB disk, while the disk receiving this image and having the problem is 300GB (Maybe 320?)

    Just taking the information thus far given.



  • AH yeah it is a smaller drive than the original. I happen to have another one of those computers I can recreate an image using single disk resizable. If my memory serves me correctly I was having trouble getting it to create an image that way. I will update this when I run into problems.


  • Moderator

    @jeffj one of the devs are traveling right now but hit me on IM.

    He’s saying it appears the image was captured as single disk non-resizable and the destination disk is smaller than the size of the original disk where the image was captured from. Is this possible? Your target disk is 298.1GB in size.



  • 0_1492545514771_20170418_145547.jpg


  • Moderator

    @george1421 I would just thinking there is one more bit of info they will ask for.

    On the fog server console, change to the images directory and the image name you are trying to deploy.

    In there run the following command cat d1.partitions and post the results here. That file describes what fog should push to the target computer.

    Silly question too, what this image captured as single disk resizable?


  • Moderator

    @jeffj Well I think we are at a point in debugging where we need to ping the @Senior-Developers to see if they understand the issue.

    The only other thing is if your source image is some how incomplete. But instead of me guessing at it, lets let them take a look .



  • when entering fdisk and selecting ‘n’ command it tells me all space for primary partition in use at the top of the first image it cut off the command but i used ‘p’ to print the partition tables the rest of what I did is in the picture.
    0_1492544194013_20170418_143054.jpg

    After running the ‘fog’ command it still fails with the same error I also rechecked the partitions using lsblk and it is how it was before the image deploy command.

    0_1492544359441_20170418_143156.jpg


  • Moderator

    @jeffj Well this is a little unexpected and expected at the same time.

    your disk /dev/sda doesn’t contain any partitions (like it was new out of box). I know there was some code changes around this condition to solve another problem.

    Do you know how to use fdisk to create a new partition? All we need is just one partition no matter what size.

    fdisk /dev/sda
    (now these key strokes are from memory which I don’t trust)
    n (new)
    p (primary)
    1 (partition)
    (enter for start block)
    (enter for end block)
    p (print disk structure)
    w (write)
    x (exit)
    Then run the lsblk command again, it should list a single partition.
    If that is good then key in
    fog and press enter at each break point to continue to image the machine.



  • here is the requested information
    0_1492542951747_20170418_141304.jpg


  • Moderator

    Well on the plus side you are booting fine into FOS.

    It appears there is an issue with either the disk or FOS talking to the disk.

    What I want you to do is setup the deploy job again, but this time before you select the schedule task button select the checkbox that says debug. Then pxe boot the target computer. After a few enter key presses on the target computer FOS will drop you to a command prompt.

    Please post the output of these two commands.

    1. df -h
    2. lsblk

    These two commands will describe the disk according to how FOS sees the disk


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.