DriverStore Replication Issue



  • Server
    • FOG Version: 1.3.5
    • OS: Ubuntu 16.04
    Client
    • Service Version: 0.11.11
    • OS: Windows 7 Ent. 64bit
    Description

    Since I upgraded to Fog 1.3.5 I notices that the “postdownloadscripts” folder is no longer replicating between my nodes since 1.3.x. This is an issue because this was the location where i was storing the Drivers and Programs for my clients after the Image process was complete. I have been trolling through the Forums and I found where a few people suggested making a dummy image and place your drivers in there. So I gave that a shot and it was only replicating files inside of the dummy image directory one tier deep, none of the folders or subfolders and files were being copied over. This wouldn’t be a huge issue if I didn’t have to manually sync the directorys on 20+ Fog Servers and Storage Nodes every time we change something. I’m sure there is a simple solution, I am just not seeing it.

    Thanks for any assisstance.


  • Developer

    in the interim, you could always setup rsync until toms worked his magic :-)


  • Senior Developer

    @FlareImp this is because the fundamental way replication occurs has changed. I’m working to add in auto replication of the postdownloadscripts directory though. Same for postinitscripts.



  • @falko, The postdownloadscripts folder was syncing in Fog 1.2.0 but I noticed it stop once I changed over to 1.3.x. I never had to manually sync my drivers directory once it was placed on the Fog server. It auto populated onto the nodes for that site.


  • Moderator

    I use a dummy image to replicate drivers and all items/folders/subfolders sync.

    I don’t have my nodes anymore but last time I checked i didn’t think post download scripts synced between nodes @Wayne-Workman ?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.