SOLVED Dell XPS13 with Displaylink DA100

  • Hi All,

    I’m using Fog 1.3.0-RC-36

    I’ve just received a Dell XPS13 which I’ve just reinstalled Windows10 and updated the Dell drivers - esp the Dell Displaylink DA100 which I use to plug in to the network cable for Fog imaging.

    Regardless of what I’ve done, when I boot the Dell laptop into BIOS I do not see the network boot option in this Dell laptop , like I did for my lenovo laptops and desktops. There’s only 2 boot sequence options: Windows Boot and UEFI Samsung SSD PM851 M2.2280 256GB

    Has someone had a similar issue, appreciate some suggestions how to PXE boot this machine ?

    Mod edited to clean up horrible non-existent word, sorry sometimes things catch my eye.

  • Many thanks george1421 . The FOS method worked. I was able to capture the image finally 🙂 Case closed.

  • @george1421 ok thanks george1421, I’ll try this out.

  • Developer

    @froydo to get it to work natively, you’ll need to buy a supported adapter. it looks like Dell makes one that will work:

  • Moderator

    @froydo Well if Plan B doesn’t work there is a Plan C, but we loose the tight integration between FOG and FOS. It does work but you have to follow the rules.

    If you USB boot FOS, you MUST tell the FOG server to image/capture before you boot with the FOS USB stick. So if you want to capture an image, you setup the FOG server to capture and have an active task out there pending, then USB Boot FOS and it will work very nice.

  • @Junkhacker I plugged in the ethernet into the Dell laptop via the dock and dock to usb when trying to boot via the usb stick where ipxe is on another usb port, and I’ve changed the dock - unfortunately only one type we have over here - so no surprise it didn’t work either - same dhcp fail message. Any other ideas I can try to pursue ? It feels so close but yet so far…

  • Developer

    @froydo this may seem like a silly test, but try having both plugged into the computer and ethernet. i’ve seen situations were a nic was supported by bios for pxe (and would load ipxe) but ipxe didn’t work well with that nic (so it wouldn’t work) but if another adapter was connected that ipxe DID work well with, it would switch over to using that one. after all, ipxe will attempt using all available network adapters once it’s loaded.

  • @george1421 Hi george1421 , yes it is sad 😞 I was jumping for joy when I saw the initial ipxe message and it didn’t get very far. And no there was no mac address reference. I’m still using the Displaylink dock DA100 - we only have these types to plug into the usb for the Dell pcs. Anyway I will check with my office manager on Monday if she has other types just in case.

  • @Junkhacker no problem Junkhacker at least there are alternatives

  • Moderator

    @froydo Well that is a bit sad. Do you see any reference to a mac address? If not then iPXE can’t see the nic. What is going on the iPXE kernel doesn’t appear to have the driver for that displaylink adapter.

    Do you have an older usb 2 to ethernet adapter? Since we aren’t using the built in PXE firmware we can use any usb to ethernet adapter that is supported by iPXE.

  • @george1421 Hi george1421. I did the steps in the link , step6 , I checked everything. and now when I stick the usb in the laptop and boot from usb, I now see “ipxe…initialising devices” which is good news! But then I got the “dhcp failed” message and press s to go to ipxe or reboot.

  • Developer

    @froydo sorry to hear that. i must have been thinking of the XPS 14 or 15 (or maybe something completely different, i can’t be certain)

  • @george1421 Awesome! Thanks george1421. I’m so glad there’s an alternative, I’ll take a look at it and try that out.

  • Moderator

    @froydo OK then, now you know.

    Then on to plan B:

    I do need to refresh this tutorial since the values at step 6 have changed since dec 2015. But the idea is to get that XPS into the fog menu by usb booting using the iPXE kernel.

    You may be able to just grab the ipxe.efi off the FOG server and rename it so that it matches the uefi boot image file and try it that way. You may have to manually enter the fog server IP but that will tell you if its going to work or not.

  • Just spoke to the Dell technical support side on the phone. They said this particular Dell XPS 13 does not support PXE network booting at all. 😞 So it doesn’t matter if the Displaylink dock supports PXE boot or not.

  • @george1421 Hi george1421, yes its an official Dell dock - has a Dell logo embossed on it too. I’m reaching out to both Dell and DisplayLink now to confirm which dock model will work with PXE boot for my Dell XPS. Thanks for your pointers too.

  • @Junkhacker Hi Junkhacker, oh I’ve stopped trying the dock…since it looks like the DA100 displaylink dock which I am using does not support PXE boot. I’m reaching out to the Displaylink support already and ask them about it …and which of their products actually support PXE booting.

  • Moderator

    I guess the question that needs to be asked is:

    1. Is this an official Dell dock for the XPS13
    2. Does Dell say that pxe booting is supported in this dock.

    If the answer is no to the above, then you need to look for a Dell usb ethernet adapter that supports pxe booting. They are out there. There has been references to them in the forums from last summer, they were about $45USD and supported PXE booting.

  • Developer

    @froydo are you trying with a pxe supported usb network adapter, or are you still trying the dock? the adapter must be supported for boot by the computer’s firmware, and we have not established that this dock is.

  • @froydo I would side with this agreement. While I’m not familiar with the dock or device you’re referring to, I would have to say if everything’s been looked at, then probably that device isn’t supported on that particular computer.