FOG Snapin not working on Legacy Client on Fog Version 1.3.5 RC4



  • Server
    • FOG Version: 1.3.5-RC-4
    • OS: Centos 7
    Client
    • Service Version: Legacy Client
    • OS: Windows 7
    Description

    When I try to push a snapin to client machines, the snapins do not run. This was working correctly on version 1.3.4, but stopped working after I upgraded. I have attached the client log file to this thread. The most relevant line in the log file states:

    “Snapinclient module is disabled globally on the Fog Server, exiting.”

    I checked the web server setting and it showed that the snapinclient service is enabled.

    0_1486745907204_fog.log

    Thanks!!



  • @Tom-Elliott

    Hi tom That fixed the problem, Thanks for all your help!!



  • @Joe-Schmitt

    Hi Joe,

    I have tried the new client in our environment and it did not work. Sadly I ran out of time and kept the old client on our workstation since it seemed to work. Sadly I have not tried to troubleshoot it since, but I will be working on upgrading this summer since we are upgrading all of our workstations to Windows 10.

    Thanks,


  • Senior Developer

    Corrected for in the working-1.3.5 branch. Before I push anything else out Please install or just run:

    wget -O /var/www/fog/lib/client/fogclient.class.php https://raw.githubusercontent.com/FOGProject/fogproject/a94128160f896e0792a334b0d96b95e813b657e4/packages/web/lib/client/fogclient.class.php

    This should fix the legacy client and snapins for you.


  • Senior Developer

    @Kleber while we do try to maintain legacy client compatibly, we only do so to help those transitioning from 1.2.0 to 1.3.X. Legacy client compatibility is not something at the top of our backlog, and is often an pain to deal with simply due to how the legacy client was designed. In the future, legacy client support may be completely phased out as well.

    We’ll still try to patch these issues, but ultimately you should be switching over to the new client.


Log in to reply
 

454
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.