Fog Legacy Client hostname changer not working 1.3.5 RC2



  • Server
    • FOG Version: 1.3.5 RC2
    • OS: Centos 7
    Client
    • Service Version: Legacy Client
    • OS: Windows 7
    Description

    Noticed that when pushing image the computer does not auto rename or join computer to domain. I notice that log file indicated that the hostnamechanger service has been disabled globally on the fog server. I checked and it is enabled.



  • @Tom-Elliott

    Hi Tom,

    according to the client log file it says " snapinclient module is disabled globally on the FOG Server, exiting."

    I will create a new issue, and post the log file from one of the clients.

    Thanks!


  • Senior Developer

    Also, please post this new issue on a new thread. As the contents of this thread were pretty specific.

    I will try to replicate the problem myself, but it’s much easier if you can provide as much detail as possible.


  • Senior Developer

    What does it show for the snapins? When dealing with the client, the logs always go a lot longer way than just telling us a particular point doesn’t work.



  • Just installed Fog version 1.3.5 RC4 and it corrected the hostname changer problem under the legacy client. Unfortunately snapin deployment do not work.


  • Senior Developer

    So I found the issue and I’m sorry, I was wrong. While I did make improvements to ensure the legacy client worked I am just more coding for the “new client”. I forgot that the legacy client uses 2 checks to get their information. First check is a call to servicemodule-active and the second is to the enabled items. The problem was from the servicemodule-active check. For the new client we collect all the data at once and send it in a single request. To do this relatively easily there’s a variable that get’s set and is tested against. This variable was not getting set for the servicemodule-active checks.

    My client tests were working properly only because I forgot to update the server they communicate with. (Yes I have multiple servers and it’s easy for me to mistake sometimes with this.)

    For this reason, I’ve pushed up RC-4.

    Please update and keep us informed?

    Thank you.


  • Senior Developer

    @Kleber I need you to please re-pull and install. I assure you this is fixed in the latest.

    You can validate this by going to a browser and going to the url:

    http://ip-of-fogserver/fog/service/hostname.php?mac=<macaddressofhost>

    You should see something similar to:

    #!ok=<yourhostshostname> #AD=1 #ADDom=<yourdomainname> #ADOU= #ADUser=<yourdomainname>\<yourdomainusername> #ADPass=<yourfogcryptedpassword>


  • Hi,

    I updated to:

    Thu Feb 09, 2017 13:15 pm
    Running Version 1.3.5-RC-3
    SVN Revision: 6066

    I am still having the same problem. I attached the log from one of the clients.0_1486664368264_fog.log


  • Senior Developer

    Moved to bugs, and this is fixed in RC-3


Log in to reply
 

475
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.