Error trying to restore GPT partition tables



  • Server
    • FOG Version: 1.3.0-RC-36
    • OS: Ubuntu
    Client
    • Service Version: iMac12,1
    • OS: Mac OS
    Description

    Hey

    Je ne comprend pas pourquoi j’ai ce message d’erreur!

    0_1484141172963_IMG_3836.JPG

    Auriez-vous une idée ?

    Voici les fichier qu’il y a à l’intérieur de l’image dans le dossier /images/CO515

    -rwxrwxrwx 1 root root       20480 janv. 11 11:22 d1.mbr
    -rwxrwxrwx 1 root root         351 janv. 11 11:22 d1.original.uuids
    -rwxrwxrwx 1 root root    18447700 janv. 11 11:22 d1p1.img
    -rwxrwxrwx 1 root root 76730429143 janv. 11 12:00 d1p2.img
    -rwxrwxrwx 1 root root   516245735 janv. 11 12:00 d1p3.img
    -rwxrwxrwx 1 root root 43183699730 janv. 11 12:26 d1p4.img
    -rwxrwxrwx 1 root root         755 janv. 11 11:22 d1.partitions 
    

    0_1484141351051_Capture d’écran 2017-01-11 à 14.28.42.png

    Dans le dossier Operating System J’ai essayé avec Apple Mac OS et cela donne le même message d’erreur

    Merci de votre aide


    Hey

    I do not understand why I have this error message!

    0_1484141172963_IMG_3836.JPG

    Do you have an idea ?

    Here are the files inside the image in the folder /images/CO515

    -rwxrwxrwx 1 root root       20480 janv. 11 11:22 d1.mbr
    -rwxrwxrwx 1 root root         351 janv. 11 11:22 d1.original.uuids
    -rwxrwxrwx 1 root root    18447700 janv. 11 11:22 d1p1.img
    -rwxrwxrwx 1 root root 76730429143 janv. 11 12:00 d1p2.img
    -rwxrwxrwx 1 root root   516245735 janv. 11 12:00 d1p3.img
    -rwxrwxrwx 1 root root 43183699730 janv. 11 12:26 d1p4.img
    -rwxrwxrwx 1 root root         755 janv. 11 11:22 d1.partitions 
    

    0_1484141351051_Capture d’écran 2017-01-11 à 14.28.42.png

    In the Operating System folder I tried with Apple Mac OS and this gives the same error message

    Thank you for your help



  • Hey @Tom-Elliott

    I have reformed my server with the update of Fog in 1.3.4

    0_1486026540878_Capture d’écran 2017-02-02 à 10.05.48.png

    I Capture the image from my MAC and by deploying I have the error message again except that now I have one more line that tells me about the kernel.

    0_1486026711761_IMG_3880.JPG

    Below is my kernel version. Should I test with different kernels?

    0_1486026666640_Capture d’écran 2017-02-02 à 10.10.34.png

    Thank you for your help to the community.


    Bonjour @Tom-Elliott

    J’ai fais reformater mon serveur avec la mise à jour de Fog en 1.3.4

    0_1486026540878_Capture d’écran 2017-02-02 à 10.05.48.png

    J’ai télécharger l’image de mon MAC et en déployant j’ai à nouveau le message d’erreur sauf que maintenant j’ai une ligne en plus qui me parle du kernel.

    0_1486026711761_IMG_3880.JPG

    Ci-dessous voici ma version de kernel. Dois-je faire le test avec différent kernel ?

    0_1486026666640_Capture d’écran 2017-02-02 à 10.10.34.png

    Merci de votre aide la communauté.


  • Senior Developer

    @melvinpaz Would you mind installing FOG 1.3.3 official?

    There was a bug introduced that had impacted restoring GPT partitions that I’m pretty sure is fixed in the 1.3.3 version of FOG.



  • Hy

    I reset the server. I installed Ubuntu and then the latest Fog update. Everything worked correctly I even managed to capture and deploy an image of a MacMini without worries. When I put on the IMac I capture the image again on Fog. Then at the time of the deployment I found the same error message with a command line to test “sgdisk -gel /images/CO515/D1.mbr /dev/sda”

    0_1484836167705_IMG_3838.JPG

    So I tried this command on the server and there is the drama. After restarting the machine this is the message I had

    0_1484836266203_IMG_3866.JPG

    I tried everything and could not retrieve the data from the server. So I reinstall everything and do all the operations again. Installing Ubuntu, Fog, Capturing and deploying the MacMini is ok. Same operation for the IMac I had the same error message I retype the same command line on the server and I have my server that had the same worries. I do not think this command line is the right one. Do you have any other solution?

    I may have a complementary information to add you there is on this IMac a DualBoot with windows. The hard disk of the IMac is partitioned into 2 a MAC image and a PC image. There is no DualBoot on the MacMini


    Bonjour

    J’ai remis à zéro le serveur. J’ai installer Ubuntu puis la dernière mise à jour de Fog. Tout fonctionnais correctement j’ai même réussi à capturer et déployer une image d’un MacMini sans soucis. Quand je me suis mis sur l’IMac j’ai capturer à nouveau l’image sur Fog. Puis au moment du déploiement j’ai retrouvé le même message d’erreur avec une ligne de commande à tester “sgdisk -gel /images/CO515/D1.mbr /dev/sda”

    0_1484836167705_IMG_3838.JPG

    J’ai donc essayé cette commande sur le serveur et là c’est le drame. Après avoir redémarrer la machine voici le message que j’avais

    0_1484836266203_IMG_3866.JPG

    J’ai tout essayé et impossible de récupérer les données du serveur. J’ai donc tout réinstaller et refais toutes les opérations. Installation de Ubuntu, Fog, Capturer et déployer le MacMini c’est ok. Même opération pour l’IMac j’ai eu le même message d’erreur j’ai retaper la même ligne de commande sur le serveur et j’ai mon serveur qui a eu le même soucis. Je ne pense pas que cette ligne de commande soit la bonne. Avez-vous d’autre solution ?

    J’ai peut être une information complémentaire à vous ajouter il y a sur cette IMac un DualBoot avec windows. Le disque dur de l’IMac est partitionné en 2 une image MAC et une image PC. Il n’y a pas de DualBoot sur le MacMini


  • Moderator

    Did you recapture the image after changing the image type to Apple Mac OS?


  • Senior Developer

    Mind repulling and reinstalling?

    While I suspect your GPT layout will cause an issue, I’ve added a bit of code to more neatly address the output (it will put the error on a new line and end that line with the proper message). I’ve added, however, the exact command it’s trying to run and the exit code that message is returning. If you can upload the new output information it should be greatly helpful.


  • Senior Developer

    @melvinpaz Can you provide a newer screenshot of the error? I doubt there will be much change, but I want to verify where things are “failing” for sure.



  • Hey

    J’ai fais la mise à jour

    0_1484154839117_Capture d’écran 2017-01-11 à 18.12.31.png
    0_1484154945073_Capture d’écran 2017-01-11 à 18.15.25.png

    J’ai téléchargé à nouveau l’image MAC sur le serveur sans soucis et en voulant la déployer j’ai le même problème.
    https://forums.fogproject.org/uploads/files/1484141176443-img_3836.jpg

    Quand je travaillais sur la version 1.2.0 de FOG les images MAC fonctionnaient correctement

    Actuellement je n’ai pas de machine MAC dans mon parc se sont les premières que l’on déploie avec la nouvelle version de FOG

    Auriez-vous une autre idée ?


    Hey

    I made the update

    0_1484154839117_Capture d’écran 2017-01-11 à 18.12.31.png
    0_1484154945073_Capture d’écran 2017-01-11 à 18.15.25.png

    I downloaded the MAC image again on the server without worries and wanting to deploy it I have the same problem.
    https://forums.fogproject.org/uploads/files/1484141176443-img_3836.jpg

    When I was working on version 1.2.0 of FOG the MAC images were working correctly

    Currently I do not have a machine MAC in my park are the first one deployed with the new version of FOG

    Would you have another idea?


  • Moderator

    Seeing as you were on an RC before, there are now RCs available for 1.3.1. Please update to the latest via these instructions:
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk
    No promises, but something as simple as this could fix your issue.

    Also, just some general troubleshooting questions I would ask are:

    • Has FOG ever worked with an iMac 12,1 for you?
    • Do other iMac 12,1 computers image or not?
    • Does other iMac models in your environment image with fog or not?

    Also I’m pinging @Sebastian-Roth because of his Mac knowledge.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.