HP 400 G3 network card issue



  • We have been using FOG for a few years here at our company, We have our image created in VM, and we have our multi device driver image setup to run (setupcomplete.cmd) script upon completion to detect which model is being imaged and then copy the correct driver packs to a folder on the computer then we have the script run SAD2-111118 (DP_Install_Tool.cmd) …to detect and install drivers needed etc…

    During the process usually all the drivers for the specific model gets installed 100% of the time…

    With our newest model HP 400G3 we have been seeing an strange issue…

    While the drivers are getting installed and etc… Everything seems to be good to go, then the PC does its final reboot & this is when the issue appears…

    The issue is once the PC reboots the LAN has a yellow ! on it and it is not working, even after multiple reboots, or removing & reinstalling the drivers for the LAN it still has the same yellow ! on the LAN

    I did some testing, and the only thing that I can do to fix the issue is to power down the PC, and unplug the power, press the power button to drain all power form the capacitors etc… Once that is complete it boots up and the LAN is working normally!

    So, my questions here in the Forum…

    has anyone else seen an issue like this??
    Does anyone have any idea what could be going on??

    At the end of the day, power draining/rebooting is not the end of the world… but would be nice to know what is going on!

    Thanks in advance to anyone lending any thoughts

    Jason


  • Senior Developer

    @Joseph-Hales it deals with the firmware that might be applied. while this is typically reset on reboot, windows firmware applied holds in the NICs ROM. The fog inits load their own firmware in a temporary state.


  • Testers

    We never were absolutely sure what was happening best guess was that older PXE boot files induced an error state in the NIC hardware on boot to menu that is resolved in the 1.3.x versions.


  • Moderator

    @george1421 Not sure I’m missing something, but how would a newer version of FOG what seems to be a Windows NIC driver issue?


  • Moderator

    @Joseph-Hales said in HP 400 G3 network card issue:

    We saw this on the G3 and G4 models but it seems to be resolved in the latest version of FOG SVN 6050 in our case.

    Valid point, we (I) never asked the OP what version of FOG was being used, this issue may have already been address in FOG 1.3.x.


  • Testers

    We saw this on the G3 and G4 models but it seems to be resolved in the latest version of FOG SVN 6050 in our case.



  • Thanks for the replies…

    This is on Windows 7 Pro installations…

    Just wish I could figure out the issue… Even though power cycling/draining is not the worst thing to fix it… just hoped there was something I was missing…

    Thanks

    Jason


  • Moderator

    I had one model of the intel nucs do this. It had one of those realtek ethernet chips in it. After imaging (perfectly) the network would not operate until we powered off the unit and unplugged the device. If I remember correctly a firmware update resolved the issue.

    I’ve also seen driver shadowing cause a similar issue. Whereas there is another driver that shares the same hardware ID as the proper driver, but the older driver is discovered first and loaded before the proper one was loaded. We had the issue with a Dell 780 where if the “MS” driver was used for the audio the internal speaker was not enabled, but if we removed the MS driver and loaded the Dell audio driver the internal speaker worked. While that is a bit off-point, it does make me wonder if the wrong driver or an older one for the same model is being loaded causing the network outage.


  • Moderator

    I’ve seen this many times. However in each case, network communications still work though. Is communication hindered in your scenario?

    More info: I’ve only seen this on Win7. I’ve not seen it on Win10.

    I remember someone at my old job saying it’s a known bug (I assume in Win7) - I didn’t look into it though. I never cared because things still worked fine.


Log in to reply
 

515
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.