UNSOLVED Windows 7 errors post deployment

  • Server
    • FOG Version: 1.3.0-RC-20
    • OS: CentOS 7
    • Service Version: 0.11.5
    • OS: Windows 7

    A group of 60 computers, all with nearly identical hardware, seem to have some that have issues when installing post sys-prep. Some of these computers seem to work fine, others seem to give the error of "Windows could not complete the installation. To install windows, restart the installation.”

    There doesn’t seem to be any reason for this, as the exact same image, when captured and deployed using Clonezilla, works perfectly fine.

    I did disable the fog client per the instructions found here: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep

    It is only some workstations, not all.

  • @sourcaffeine

    Moved topic to Windows problems. Please advise if you’ve found a solution to this or are still having the problem.

  • before imaging (‘syspreping’) look at the line :
    Remaining windows rearm count : x
    in the command line console prompt of :
    slmgr.vbs -dlv
    perhaps it’s reached 0
    If so, Look at rearm technic on the net.

  • I was unable to correct this issue with FOG. I verified a number of times that the FOG Client was indeed disabled, even to the point of uninstalling it and going from there. The same issue came up. I attempted to swap hard drives of one that worked, and one that didn’t, same issue.

    Verified all BIOS settings were the same. Deleted the host from FOG, tried to manually deploy, no luck.

    I did end up using Clonezilla Server and it deployed without a single issue.

  • I have also seen this error caused by the Antivirus in the image. Although it affected all deployments, effectively poisoning the image beyond repair.

  • Moderator

    Have you taken 2 of these systems (one that imaged and one that has not) and done an actual side be side comparison to ensure the model, included hardware, bios, bios settings are all consistent?

    As I said before I’ve also seen this action with a bad windows driver. When you did the shift-f10 trick and was able to boot into windows, did you review the OOBE logs in either windows\panther or windows\sysprep folders? Those logs should tell you what was going on when the system rebooted.

    One thing that is also not clear, are you using one image for all, or do you have one image per hardware model?

  • @sourcaffeine The message you’re seeing would be coming from Windows, at which point this is not anything FOG is doing.

    You state that you’re using Clonezilla and it works perfectly, except we haven’t got a full testbed.

    If you take the same image from FOG, deploy it, and clone it using clonezilla, then deploy using clonezilla, it should do EXACTLY the same thing.

    Why? Because FOG uses the same tools Clonezilla uses for imaging.

    If this where something FOG was doing, you’d see the exact same problem on all systems in the exact same way.

  • Also, I was searching on the forums for the error and found this old thread, and it was due to the fog client not being disabled on the image:

    @zpoling said in Windows Fails to Install:

    Specifically on our HP Probook G1 laptops, after deployment I am getting an error on the boot screen that says, “Windows Setup could not configure Windows to run on this computer’s hardware.” The message displays for a only a second, then the machine reboots. I then get the following error, “Windows could not complete the installation. To install Windows on this computer, restart the installation.” This error will stay on screen until I click okay.

  • @Wayne-Workman +1 to the mixed HDD modes. I about tore my hair out one week over some hosts being set to IDE and others AHCI.

  • @sourcaffeine Well if these 60 computers are all identical besides the HDD, then taking an image from one that deployed correctly isn’t going to prove or disprove anything, because the original image also deployed correctly on some of these systems.

    For a sanity check, check the free space on the server, look for partitions that have 100% use:
    df -h

    The error you gave in the OP, that’s not the one that is typically given when the FOG Client is causing the issue. The error literally says “could not complete the installation…” The installation of what? My guess? Drivers, maybe some weird attached device like a scanner or printer or flash drive or SD Card, we’ve actually seen times where an SD card that people left in laptops will cause issues for capture/deploy sometimes.

    But, I’m going to guess drivers.

    There’s some simple troubleshooting to figure out what’s going on.

    To test if it’s the FOG Client causing the issue (which I don’t think it is), just delete these 60 hosts from fog, and manually using the boot menu do “Image Deploy” with the correct image. When the computers boot after imaging, the FOG Client will communicate with the server but not get any commands to do anything in this case. If this works fine consistently, then the FOG Client is probably not disabled on your reference image. If this doesn’t make a difference and the systems are still having issues booting after imaging, it’s probably at that point that it’s a driver related issue like @george1421 said, and I’d follow his advice.

    Another very simple thing it could be - mismatched HDD operation modes in the firmware, and mixed operation modes, or the image is BIOS but some of the machines are in UEFI mode in firmware.

  • @Wayne-Workman I described the hardware differences below. The only difference in hardware is hard drive model, and this issue does not seem to occur on any particular brand (three different models).

    Like I said in my previous post, I went ahead and captured an image using FOG on a machine that deployed and installed. I once again disabled the FOG service, and this time the deployment didn’t finish. There was an error that was obscured, with FOG just reporting that there was an error while trying to expand sda2, and that it would reboot in 1 minute.

  • @sourcaffeine “Nearly Identical Hardware” and “Some workstations, not all” isn’t detailed enough. How many variations in hardware, exactly? Exactly what workstations fail? Which models fail?

  • @Tom-Elliott

    As I said in my original post, the FOG Client is definitely turned off following all the proper instructions linked. I double checked this before posting, took an image again, and again the same problem.

    Absolutely every computer is the same model, from the same manufacturer. The only difference is the brand of hard drive in some of them (in this case, the brand of hard drive doesn’t seem to be making a difference).

    I have successfully been able to boot into windows by pulling up a command pompt, running the MSOOBE command and creating a new account, but that is only on a few of them. I can’t imagine this is from anything but FOG, as Clonezilla (live, not server) works perfectly fine in every case on on the computers FOG failed on.

    I am now (for testing purposes only), attempting to clone an image from a successfully installed system, and deploy to some of the computers that had an issue.

  • Moderator

    @sourcaffeine said in Windows 7 errors post deployment:


    A group of 60 computers, all with nearly identical hardware, seem to have some that have issues when installing post sys-prep. Some of these computers seem to work fine, others seem to give the error of "Windows could not complete the installation. To install windows, restart the installation.”

    When I’ve seen this it is because the installation has rebooted in an incorrect time. There are two common causes I’ve seen so far.

    1. Before you sysprep’d the image you forgot to disable the FOG service. Whereas during the OOBE setup of the system the FOG Service kicks in too soon to rename the system and reboots the target system before OOBE setup has completed. Typically what we will do is disable the FOG service before sysprep and then enable it again in the setupcomplete.cmd file. When setup complete has been run the OOBE setup parts have finished.

    2. You have a bad driver that is causing the computer to spontaneously restart when the driver is installed. There is a way when you get that “to install windows, restart the installation” message. It like shift-f3 to bring up a command window and then you need to run regedit and flip a registry value. When you reboot the system will come up so you can inspect the event logs to what really happened.

    Well I was so close, and yet still wrong, its shift-F10. Look at the accepted answer here: http://answers.microsoft.com/en-us/windows/forum/all/error-message-the-computer-restarted-unexpectedly/b770f14d-e345-e011-90b6-1cc1de79d2e2

    But I’m still thinking its the fog service doing this to you. Since it seems like its seeming random. The fog service only done things when it checks into the FOG server, and that is on a timer.

  • Seeing as it isn’t hurting ALL systems, and FOG uses Partclone as the “capture” medium (which is what clonezilla uses), did you clonezilla to ALL of the systems?

    What’s most interesting is FOG has already exited, so this is definitely not something with fog (as it’s already booting into windows – meaning the deploy worked just fine).

    Are you using the FOG Client on the image? If so was the client disabled before you uploaded the image? This is stated here for more understanding: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep

    If it is please try recapturing while the client is disabled. If not, it would seem this may be due to either rearm being reached (windows typically only allows 3 re-arms) or there is significant enough hardware changes that it’s triggering the system to not know what to do.