TFTP not working. Timeout



  • Server
    • FOG Version: 1.3.0-RC-16
    • OS: Centos 7
    Client
    • Service Version:
    • OS: Windows
    Description

    when i test to connect to tftp i get a timeout:
    C:\Users\Rene>tftp -i 192.168.2.233 get undionly.kpxe
    Timeout occurred
    Connect request failed

    DHCP is done by router but for this the DHCP is not needed so not the problem.
    i tryed everything on the web i could find but notthing seems to help.
    dit clean install centos 7 and then the fog install.

    when i disable firewall still same problem. :(



  • @george1421 No idea. But the default settings for Win7 and Win10 don’t let tftp commands work. It took me a long time to figure that out, because I was thinking exactly as you were, that all outbound was allowed. There must be more to it that causes the issue - and I don’t have any desire or need to figure out why lol. Incredibly rarely do I myself need to test tftp from windows… because I always just use Linux now.



  • TFTP working now :) Thank you all!!
    great support here!!

    Windows DHCP server configured
    Installed the new Fog
    and for connecting tftp from windows 10 tot test the firewall of windows was blokking it so thats way it failed. my windows firewall is standard. so standard it blocks using tftp like: C:\Users\Rene>tftp -i 192.168.2.233 get undionly.kpxe

    hope it is no problem for managing windows 10 computers bij remote with the fog client.


  • Moderator

    @ReneWerk I’m failing to see how windows comes into play here?
    https://forums.fogproject.org/topic/8871/tftp-not-working-timeout/5#
    Well, depending on your windows firewall default settings, all outbound connections should be allowed by default.

    But the part that is troubling me a bit is the OP was attempting to test if tftp is working for some reason (maybe because pxe booting is not working at all??). The OP is using a router for dhcp according to his first post. Depending on the router he may not be able to set dhcp options 66 and 67 in the router, which means that dnsmasq might be needed in this setup to supply the missing dhcp values to get this kit working as needed.


  • Senior Developer



  • Thanks, did update of fog and disable windows firewall and working now.
    witch poort or something must be open in the windows firewall?



  • Windows firewall would also cause that command to fail. This is talked about in our Troubleshoot TFTP wiki article.


  • Senior Developer

    Also. please validate if selinux is in permissive or disabled mode.

    You can verify by running:

    sestatus

    If you notice it says enforcing still, run:

    setenforce 0

    Edit the /etc/config/selinux and change the “target=enforcing” to read as “target=permissive”

    Save the file and and reboot for the changes to take effect.


  • Moderator

    ok lets start out with the basics since you are trying to tftp directly.

    Ensure the centos firewall is disabled per the install instructions as well as selinux is disabled (if it was selinux you would have more troubles by now).

    service firewalld stop


 

393
Online

41.9k
Users

12.4k
Topics

116.8k
Posts