Chainloading error when imaging from FOG boot menu


  • Moderator

    Server
    • FOG Version: 1.3.0 RC-16 as of a few hours ago.
    • OS: Fedora 21
    Description

    I have a registered EliteBook 8730w that has worked in the past fine. When I network boot it to the fog boot menu and choose Deploy Image, and pick the correct image, I get a chainloading failed error, pictured below.

    We have hidden menu turned on, and there is no image associated with the laptop at the moment, I’m just picking the correct image from the list.

    When I browse to http://10.2.1.11/fog/service/ipxe/boot.php?mac=1c:c1:de:91:68:81 This is what I see:

    #!ipxe
    set fog-ip 10.2.1.11
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x01
    iseq ${platform} efi && set keyName ESC || set keyName CTRL + A
    prompt --key ${key} --timeout 4000 Booting... (Press ${keyName} to access the menu) && goto menuAccess || chain -ar ${boot-url}/service/ipxe/grub.exe --config-file="rootnoverify (hd0);chainloader +1"
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://10.2.1.11/fog/service/ipxe/boot.php##params
    

    0_1477580312512_upload-14e1e5c6-507d-4ac6-84bc-49195001ae7b


  • Moderator

    Tom says he has fixed this in RC-17, which is now released because this was a pretty major bug - in terms of hindering everyday I.T. operations.



  • This issue is also currently happening in my environment with fresh setups on Ubuntu Server 14.04.5 if that makes any differences. It seems to be affecting all hardware models.


  • Moderator

    Confirmed bug, moving to bug reports.

    I assigned an image to the host, and tried again, and there was no chainloading error.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.