Can't register hosts (no such file or directory)



  • Server
    • FOG Version: 1.3
    • OS: CentOS 7
    Client
    • Service Version: N/A
    • OS: N/A
    Description

    I just set up a FOG install on a fresh CentOS 7 VM, and I’m trying to register a host. I can boot to the point where it says “Booting (press Escape to access the menu),” and if I hit Escape there I see a menu. In that menu, selecting either “register” option or the “debug” option pops up an error saying “No such file or directory”.


  • Moderator

    @cpast The developers confirmed and fixed the issue and it was done in time to get into the RC15 release. If you have not done much configuration the easiest way to get this fog server back on track is to:

    1. If you have any configurations you want to save make sure you export the settings.
    2. Refresh the installer to RC15 (git pull or svn up )
    3. Login to mysql using mysql -u root (provide a password if you gave root a password for mysql)
    4. key in drop database fog; (understand when you do this your entire fog configuration will be gone, and then reset to default in step 6. Save what you need saved before you execute this command).
    5. Key in exit
    6. Run the installer again in the …/bin folder (this will install RC15 and rebuild the fog database)

  • Senior Developer

    @Wayne-Workman Which is fixed in the latest.

    The issue of the hidden menu coming would only happen on fresh installs.

    To fix the problem from happening at all (the hidden menu coming where not expected) just remove the database and re install. If you have definitions, (images, snapins, etc…) that you don’t want to lose, export them first.

    Re-install will properly generate the database properly now.


  • Moderator

    @cpast said in Can't register hosts (no such file or directory):

    @george1421 The issue seems to only apply to a 32-bit VM; changing to 64-bit makes registration work. Is that something expected? (the server is 64-bit)

    It’s certainly related. In your dnsmasq configuration, you are only specifying the 64 bit boot file, so of course this would not work with a 32 bit system.

    However, George’s findings show a much bigger issue.


  • Senior Developer

    @george1421 as this only happens on “fresh” installs:

    Please run:

    drop database fog;

    Then pull fresh and rerun the installer (when RC15 officially releases of course).


  • Moderator

    @Developers any ideas here?


  • Moderator

    @cpast I can confirm this is a “thing” a fresh install of Centos 7 and RC14. For dhcp I’m sending undionly.kpxe and it stops during ipxe booting

    Pressing esc brings up this panel. Logging in using the FOG console user ID and Password.

    0_1477158132895_error_login.png

    Here is what boot.php gives us.

    #!ipxe
    set fog-ip 192.168.1.193
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x1b
    iseq ${platform} efi && set keyName ESC || set keyName Escape
    prompt --key ${key} --timeout 0 Booting... (Press ${keyName} to access the menu) && goto menuAccess || sanboot --no-describe --drive 0x80
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://192.168.1.193/fog/service/ipxe/boot.php##params
    

    There was absolutely no configuration changes to this system, it was load and go. I only logged into the fog web gui to prove that the system was up.



  • @george1421 The issue seems to only apply to a 32-bit VM; changing to 64-bit makes registration work. Is that something expected? (the server is 64-bit)



  • They’re both VMs on Virtualbox, with the extension pack (so it’s using Intel PXE). I can remove that if needed. The client is 32-bit, if it matters.

    0_1477155363677_boot error.png

    The black is what it shows on boot before I hit Escape (the SAN error happened when I hit Print Screen, it otherwise says “Booting… press Escape for menu”). The white is what happens when I hit “fully register.” I’m using dnsmasq for proxy DHCP, with the following config (it was undionly before, I just now changed it to ipxe):

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=ipxe.pxe,,192.168.56.10
    dhcp-no-override
    #dhcp-option=vendor:PXEClient,6,2b
    pxe-prompt="Press F8 for boot menu",3
    pxe-service=x86PC, "Boot from network", ipxe
    dhcp-range=192.168.56.10,proxy,255.255.255.0
    

  • Moderator

    @george1421 So then I have to ask the question why? I think I still have a centos 7 template on my dev box, let me spin up a new centos server and install fog on it. Two in a week is a bit strange.


  • Moderator

    There was just this week another post very similar to this one. Trying to locate it now to cross link.

    <Edit>
    Wayne found it: https://forums.fogproject.org/topic/8780/want-to-skip-booting-press-escape-to-access-the-menu


  • Moderator

    Please post a photo of the error. Is the host you’re trying to register also virtual? If so, you’ll want to use the ipxe.pxe boot file for DHCP option 067 / filename.


Log in to reply
 

410
Online

39180
Users

10828
Topics

103047
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.