FOG Service Settings cannot be re-enabled

  • Server
    • FOG Version: 1.3.0-RC-14
    • OS: Ubuntu 14.04
    • Service Version: 0.11.5
    • OS: Windows 10 Pro x64

    Can disable FOG Service Settings but cannot re-enable them.
    Tried checking Hostname Changer setting, but when applied it shows the box unchecked and says “saved”.

  • @Tom-Elliott
    Thanks Tom - everything seems to be working great!

  • Senior Developer

    @jquilli1 If your mysql is basically in “default state” just run:

    mysql -u root
    drop database fog;

    Then cd to the installer, repull (not that there is an update I just do it for sanity sake, ) and rerun the install like you normally would.

  • @Tom-Elliott
    I installed FOG Thursday or Friday of last week - I then just updated it right before posting this morning.
    How do I drop the FOG database and re-establish it? Would it be easier to just blow the server away and start new? I only have 1 host, no images or anything else.

  • Senior Developer

    @jquilli1 If all services are grey, this is because all services are not available.

    When did you install? I’m aware there was an issue with the database earlier which has since been fixed.

    If it’s not too late, you can drop the fog database and re-establish it.

    If you have definitions you still need (images, hosts, snapins) create exports of each element first.

  • @Tom-Elliott
    Still having issues with this. I’ve upgraded to RC-15 and it’s still not showing check boxes.
    Maybe it’s me? I’m going to Service Settings for the host - all boxes are grey except Select/Deselect All. I’ll select that box, hit update, and it’ll notify me the changes have been saved but all boxes are still unchecked.

  • Senior Developer

    Fixed in working-RC-15.

  • Senior Developer

    Issue confirmed but clarification would’ve been extremely helpful.

    How to reproduce:

    Select a host. Go to Service Settings. Uncheck all boxes. Update select only ONE item to enable, and update.

    On refresh the host will appear to still have NO modules selected.

  • Moderator

    Please give us more information. How do we reproduce this problem?

    We need verbatim click-for-click steps to reproduce the issue from scratch.

  • Moderator

    This post is deleted!

Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.