• Running 1.3.0 on Ubuntu. Everything running fine. Console is running no issues. I boot laptopo to NIC. It gets an IP address but when the TFTP runs it times out. The settings in the tftpd-hpa is as follows:

    /etc/default/tftpd-hpa

    #TFTP_USERNAME=“tftp”
    TFTP_USERNAME=“fog”
    #TFTP_DIRECTORY="/var/lib/tftpboot"
    TFTP_DIRECTORY="/etc/default"
    #TFTP_DIRECTORY="/var/www/fog/service/ipxe"
    TFTP_ADDRESS=“0.0.0.0.”
    TFTP_OPTIONS="–secure"

    The ip address is correct. On the fog server the path for the image file is set to /var/www/fog/service/ipxe which i added to the file since it wasnt working. I can manually GET files on windows and it sends. So the TFTP server is working.

    The question is why is it failing to boot into fog client?

  • Moderator

    The files of /var/www/fog/service/ipxe are in your /var/lib/tftpboot folder and the the /tftpboot folder does not exist.

    Try running the FOG installer again and hope it can fix this mess.


  • @pencils those files are not files from fog 1.3.0

    Did the installer even complete for you? Fog puts the boot files at /tftpboot and nowhere else.


  • @Wayne-Workman 0_1475652353611_Capture.PNG

    Also the switch is doing is leasing IP address and have just got it to work with the two options. Question on Option 67, the wiki says to use file name UNDIONLY.kpxe. Is this correct?


  • @pencils I’m pretty sure there is zero code in any version of fog that puts boot files anywhere but /tftpboot

    What is the output of:
    ls -lahRt /var/lib/tftpboot

    What is doing DHCP in your setup?


  • @Tom-Elliott sorry tom. I meant the TFTP service. I installed 1.3 RC release and it installed it the the DIR i have already mentioned. On the FOG server the TFTP PXE KERNEL DIR is set to /var/www/fog/sservice/ipxe?

    Should i make a copy of the folder to the root?


  • @pencils And what do you mean ftp service? TFTP and FTP are 2 VERY different things.


  • I’m very confused. Why is TFTP setup for /var/lib/tftpboot? If you installed fog, it defaults to /tftpboot, not /var/lib/tftpboot.


  • OK. The Dir is actually /var/lib/tftboot. Which was i assume installed when fog was installed.

    I have changed to reflect that now. however, Im still no closer to get the TFTP side to work.


  • added the line. now the ftp service wont load. Its saying that /tftpboot is missing.

  • Moderator

    #
    

    comments out the option (aka makes it so it doesn’t get used)

    Also, on the default FOG install, the PXE boot files are in /tftpboot


  • TFTP_DIRECTORY needs to be:
    TFTP_DIRECTORY="/tftpboot"

    Once changed restart the tftpd-hpa service.

336
Online

9.0k
Users

15.6k
Topics

145.2k
Posts