AD legacy password in RC11



  • Server
    • FOG Version: 1.3 RC11
    • OS: Ubuntu 14.04
    Client
    • Service Version: Client 1.3 and legacy client
    • OS: Windows 7 64bits
    Description

    Since RC11 I have this message when trying to join a domain:
    HostnameChanger ERROR: Required domain information is missing
    AD password was in legacy, I passed it in “Will plaintext auto-chiffrer” and now it work.



  • @Tom-Elliott
    Ok thanks


  • Senior Developer

    @Lenain when you set the non legacy field you enter the password in plain text. It well then store the field encrypted for you. It is this field that’s used for the new client.



  • @Tom-Elliott
    Hello,
    So if I set both AD and AD legacy password it will work fine?


  • Senior Developer

    This issue is you’re using the new client, but the ad password is not set, only the ad legacy field is set.


  • Moderator

    @Lenain The images are blocked for me by our web filter. Can you use Google Drive or Mega or Dropbox?



  • @Wayne-Workman
    This setting is given:
    text alternatif
    This error sometime occur:
    text alternatif


  • Moderator

    @Lenain said in AD legacy password in RC11:

    some of them got issue with Active Directory and they all got the same settings.

    Can you explain this further? Can you give us screen shots? showing what you’re saying?



  • @Wayne-Workman
    I understand your answer but it work for the greater part of our computer, just some of them got issue with Active Directory and they all got the same settings.


  • Moderator


  • Senior Developer

    @Lenain the new client uses a different system for protecting your AD password. You have to fill in the fog ad password field on your host / group in plain text.



  • @Tom-Elliott
    Hello,
    The problem came again with client 0.11.5:

    12/10/2016 16:21 Middleware::Communication URL: http://srv-image/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     12/10/2016 16:21 Middleware::Response Success
     12/10/2016 16:21 Service Sleeping for 127 seconds
     12/10/2016 16:23 Middleware::Communication URL: http://srv-image/fog/management/index.php?sub=requestClientInfo&mac=48:0F:CF:59:6A:81||00:00:00:00:00:00:00:E0&newService&json
     12/10/2016 16:23 Middleware::Response Success
     12/10/2016 16:23 Middleware::Communication URL: http://srv-image/fog/service/getversion.php?clientver&newService&json
     12/10/2016 16:23 Middleware::Communication URL: http://srv-image/fog/service/getversion.php?newService&json
    
     12/10/2016 16:23 Service Creating user agent cache
     12/10/2016 16:23 Middleware::Response Invalid time
     12/10/2016 16:23 Middleware::Response Module is disabled globally on the FOG server
     12/10/2016 16:23 Middleware::Response Module is disabled globally on the FOG server
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Success
     12/10/2016 16:23 HostnameChanger Checking Hostname
     12/10/2016 16:23 HostnameChanger Hostname is correct
     12/10/2016 16:23 HostnameChanger ERROR: Required domain information is missing
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response No snapins
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Module is disabled globally on the FOG server
     12/10/2016 16:23 PrinterManager Getting installed printers
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Module is disabled on the host
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     12/10/2016 16:23 Client-Info Client Version: 0.11.5
     12/10/2016 16:23 Client-Info Client OS:      Windows
     12/10/2016 16:23 Client-Info Server Version: 1.3.0-RC-11
     12/10/2016 16:23 Middleware::Response Success
    ------------------------------------------------------------------------------
    
     12/10/2016 16:23 Middleware::Communication URL: http://srv-image/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     12/10/2016 16:23 Middleware::Response Success
     12/10/2016 16:23 Service Sleeping for 101 seconds
    

    It can’t find informations for Active Directory but informations are there, I’ve uninstall client and install legacy client and it work fine.


  • Moderator

    @Lenain said in AD legacy password in RC11:

    The problem:
    In RC10 I have enter AD password with “FOG Crypt” in FOG_AD_DEFAULT_PASSWORD_LEGACY because in FOG_AD_DEFAULT_PASSWORD the password didn’t work. So every groups have the “FOG Crypt” password.
    In RC11 this password give an error in client machine “HostnameChanger ERROR: Required domain information is missing”, with one client I’ve tried to use the “Will plaintext auto-chiffrer” and it work.
    My issue:
    Do I have to apply “Will plaintext auto-chiffrer” to all groups (it will be very long :’( ) or there is an other solution?

    If you only have 1 domain, you can very easily create a group with every computer in it, and then use this group to apply the correct Domain Name, Username, and Password in the plaintext fields.

    Other advice: Don’t use the legacy client, stick with the new one.


  • Senior Developer

    I think we need the log in whole to potentially be more help.

    It having the password or not should send the proper data for the legacy client, though I’ll admit I’m not working to maintain upkeep with the legacy client. I’ve tried to ensure things will work as best as possible, but I’d highly recommend the new client over the old.



  • @Tom-Elliott
    I’ve tried with both 1.2 client and 1.3 client, with FOG_AD_DEFAULT_PASSWORD_LEGACY same issue “HostnameChanger ERROR: Required domain information is missing”.


  • Senior Developer

    @Lenain It depends on the client that installed.

    From the sounds of things, you have the client that “worked” with the New Client.



  • @Tom-Elliott
    You are right, I misspoke… Sorry.

    The problem:
    In RC10 I have enter AD password with “FOG Crypt” in FOG_AD_DEFAULT_PASSWORD_LEGACY because in FOG_AD_DEFAULT_PASSWORD the password didn’t work. So every groups have the “FOG Crypt” password.
    In RC11 this password give an error in client machine “HostnameChanger ERROR: Required domain information is missing”, with one client I’ve tried to use the “Will plaintext auto-chiffrer” and it work.

    My issue:
    Do I have to apply “Will plaintext auto-chiffrer” to all groups (it will be very long :’( ) or there is an other solution?


  • Senior Developer

    I’m confused. You’re not having an issue?


Log in to reply
 

383
Online

39197
Users

10848
Topics

103263
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.