Replication problem with working-RC-11


  • Testers

    Server
    • Version: working-RC-11
    • OS: Centos 7
    Client
    • Version: 0.11.5
    • OS: Windows 10
    Description

    Snapins will not replicate.
    I get the follinwing in the logs:

    [09-21-16 9:35:55 am]  * Started sync for Snapin 01c - TeamViewer - Training
    [09-21-16 9:35:56 am]  | Local File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:56 am]  | Remote File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:56 am]  | Local File size: 12751804
    
    [09-21-16 9:35:56 am]  | Remote File size: 0
    [09-21-16 9:35:56 am]  | Files do not match
    [09-21-16 9:35:56 am]  * Deleting remote file: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:57 am]  | CMD:
                            lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; 'set net:limit-rate 0:393216;' mirror -c '-R -i TeamViewer-Training.sfx.exe' --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first ''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''/opt/fog/snapins'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\'''\''' '/opt/fog/snapins'; exit' -u 'fog',[Protected] '192.168.17.39'
    sh: -c: line 0: unexpected EOF while looking for matching `''
    sh: -c: line 1: syntax error: unexpected end of file
    

    and the “”\" seem to get worse with every node:

    [09-21-16 9:35:57 am]  * Started sync for Snapin 01c - TeamViewer - Training
    [09-21-16 9:35:58 am]  | Local File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:58 am]  | Remote File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:58 am]  | Local File size: 12751804
    
    [09-21-16 9:35:58 am]  | Remote File size: 0
    [09-21-16 9:35:58 am]  | Files do not match
    [09-21-16 9:35:58 am]  * Deleting remote file: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:58 am]  | CMD:
                            lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; 'set net:limit-rate 0:131072;' mirror -c '-R -i TeamViewer-Training.sfx.exe' --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first ''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''/opt/fog/snapins'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\'''\''' '/opt/fog/snapins'; exit' -u 'fog',[Protected] '192.168.18.39'
    sh: -c: line 0: unexpected EOF while looking for matching `''
    sh: -c: line 1: syntax error: unexpected end of file
    
    [09-21-16 9:35:58 am]  * Started sync for Snapin 01c - TeamViewer - Training
    [09-21-16 9:35:59 am]  | Local File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:59 am]  | Remote File: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:35:59 am]  | Local File size: 12751804
    
    [09-21-16 9:35:59 am]  | Remote File size: 0
    [09-21-16 9:35:59 am]  | Files do not match
    [09-21-16 9:35:59 am]  * Deleting remote file: /opt/fog/snapins/TeamViewer-Training.sfx.exe
    [09-21-16 9:36:00 am]  | CMD:
                            lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; 'set net:limit-rate 0:274877906816;' mirror -c '-R -i TeamViewer-Training.sfx.exe' --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first ''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''/opt/fog/snapins'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\''\'\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\''\'\''\'\'''\'''\''\'\'''\'''\''\'\'''\'''\''' '/opt/fog/snapins'; exit' -u 'fog',[Protected] '192.168.19.39'
    sh: -c: line 0: unexpected EOF while looking for matching `''
    sh: -c: line 1: syntax error: unexpected end of file
    

  • Senior Developer

    Found and fixed. Thanks for reporting.


  • Testers

    @mp12 I noticed your topic is marked as solved when its not really solved you are just using a work around.


  • Testers

    @mp12

    Thanks for the tip!



  • @Greg-Plamondon

    Mentioned that problem yesterday here.
    For temporary reasons I synced my snapins manually.

    lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; '' mirror -c -R -i SNAPIN_FILENAME --ignore-time -vvv --exclude dev/ --exclude 'ssl/' --exclude 'CA/' --delete-first '/opt/fog/snapins' '/opt/fog/snapins'; exit' -u 'fog',NODE_PASSWORD 'IP_ADDRESS_NODE'
    

    Just edit SNAPIN_FILENAME, NODE_PASSWORD and IP_ADDRESS_NODE


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.