SnapinPack Error: Version required to extract this entry not supported



  • Server
    • Version: 1.3.0-RC-8
    • OS: CentOS 7
    Client
    • Version: 0.11.5
    • OS: Windows Vista
    Description

    Following https://wiki.fogproject.org/wiki/index.php?title=SnapinPacks, i created a snapin pack for ampl software to test.
    When i sent single snapin task, the task never ended and the sotfware was not installed.
    Looking at fog.log:

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     30/08/2016 17:42 Client-Info Client Version: 0.11.5
     30/08/2016 17:42 Client-Info Client OS:      Windows
     30/08/2016 17:42 Client-Info Server Version: 1.3.0-RC-8
     30/08/2016 17:42 Middleware::Response Success
     30/08/2016 17:42 SnapinClient Snapin Found:
     30/08/2016 17:42 SnapinClient     ID: 102
     30/08/2016 17:42 SnapinClient     Name: ampl121
     30/08/2016 17:42 SnapinClient     Created: 2016-08-30 17:41:21
     30/08/2016 17:42 SnapinClient     Action: 
     30/08/2016 17:42 SnapinClient     Pack: True
     30/08/2016 17:42 SnapinClient     Hide: False
     30/08/2016 17:42 SnapinClient     Server: http://192.168.1.1/fog
     30/08/2016 17:42 SnapinClient     TimeOut: 0
     30/08/2016 17:42 SnapinClient     SnapinPack File: cmd.exe
     30/08/2016 17:42 SnapinClient     SnapinPack Args: /c "[FOG_SNAPIN_PATH]\install-ampl12.1.bat"
     30/08/2016 17:42 SnapinClient     File: ampl-12.1.zip
     30/08/2016 17:42 Middleware::Communication Download: http://192.168.1.1/fog/service/snapins.file.php?mac=00:40:A7:11:6A:27||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&taskid=102
     30/08/2016 17:42 SnapinClient C:\Program Files\FOG\tmp\ampl-12.1.zip
     30/08/2016 17:42 SnapinClient Processing SnapinPack ampl-12.1.zip
     30/08/2016 17:42 SnapinClient Extracting SnapinPack
     30/08/2016 17:42 SnapinClient ERROR: Version required to extract this entry not supported (788)
     30/08/2016 17:42 Middleware::Communication URL: http://192.168.1.1/fog/service/snapins.checkin.php?taskid=102&exitcode=-1&mac=00:40:A7:11:6A:27||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json
    

    Am i doing something wrong? What i could do to fix this?



  • @Quazz
    Now it works with 7zip too.
    Definitely something went wrong at last time.



  • @Quazz
    previously: 7-zip 16.02-x86, Windows Vista Bussiness x86 SP2.
    currently: zip 3.0-8-x64, Debian Jessie x64 (default zip package from debian).
    I think that something went wrong when I made the compression. I will try again with 7zip and report with it works.


  • Moderator

    @Thiago Can you tell us which one you used previously for reference?



  • @Joe-Schmitt
    It’s working now.
    changing zip software works as expected.
    Thanks.


  • Senior Developer

    @Thiago said in SnapinPack Error: Version required to extract this entry not supported:

    Version required to extract this entry not supported (788)

    It’s an issue with the zip file’s header. Try making the zip file with a different piece of software.


  • Moderator


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.