Lenovo ThinkPad 13



  • Hey ho, having fun with a batch of Lenovo ThinkPad 13 using the same USB Ethernet as what I used here.

    Running RC8 with kernel 4.7.1 on CentOS 7.2.1511 . The server is fine, the image is fine.

    I can PXE boot with UEFI fine, get into deploy image, select the image then it goes on its merry way, except that immediately after ok loading bzimage and init.xz, I’m stuck on a blank, black screen that gndn.

    So far I’ve tried kernels back to 4.2.0, but no luck.

    Booting in Legacy mode using undionly.kpxe is even less productive with it stalling at iPXE initialising devices…

    I’ve tried with UEFI-BIOS 1.12 and 1.14, snp.efi, ipxe.efi, onboard Ethernet enabled/disabled (it would use the One Link which I’m not using) and Secure Boot is disabled.

    I get the same results when trying to register.


  • Developer

    @Wayne-Workman If I remember correctly there was an issue that @Tom-Elliott found in the current iPXE code. Well not exactly in the code but we saw issues with binaries compiled with a later version. Tom and I talked about git-bisect-ing to find out what exactly is the problem. Unfortunately this would take a little bit of time - although not too much. It’s not too much of trouble if you have a device that hangs on that issue (is it only the surface devices or others as well??) and a couple of hours to bisect from the known working version up to current.

    Anyone keen to do this? I should be able to do the bisect-ing and provide the binaries. Who is willing to test?



  • @Tom-Elliott @Sebastian-Roth @george1421

    How can we find out what’s different about 7156’s boot ROMs?



  • We have a weiner!

    Using boot file “ipxe7156.efi” is the answer.



  • According to your old thread, you were (then) on 7394.

    There was some specialness going on with ipxe.efi then. If you read the release notes for RC-3, Tom added ipxe.efi from 7156 into fog as it’s very own file, and also left the new file.
    It’s named ipxe7156.efi, this wasn’t the only file from 7156, it appears all of them from that specific revision was added back.

    Try that one and see how it goes.



  • I assume you’ve tried 4.5.1 ?


 

550
Online

41.6k
Users

12.1k
Topics

114.3k
Posts