not possible to capture images, database connection error

  • Updated from a month old svn to rc6. Capturing an image fails when database record is to be updated (I guess) after upload is completed. Centos 6 and mysql (no changes have been made since my last svn was up and running.

  • Moderator

    @pmonstad Glad you got the problem solved. I don’t believe it’s a bug. Often times people are bit by browser auto-fill in the storage management area, it’s happened to the best of us, and I think that’s what happened here. I’ve cleaned up and locked this thread - no need to discuss more, the problem is resolved.

  • I finally figured out what was the problem: The Management password under Storage Management has been changed to some random text string. I never did it. All I did was running av svn update and this password seams to have changed. A bug?

  • Senior Developer

    I have a hard time understanding what’s wrong @pmonstad.

    Considering you are stating you’re manually changing the linux user’s password, it seems to me you’re the direct cause of this “bug”. If you updated, and all was working, why did you have to update the user’s password again? How is this a bug FOG is causing? How is this related to deploy taskings? <- (At all)

  • Moderator

    @pmonstad I recommend going over each step in the Wiki (check George’s post for a link) to troubleshoot FTP credentials.

  • Senior Developer

    @pmonstad If nothing changed, and suddenly this happens there’s an issue. But as you state: “I have set fog user password with command passwd fog” What are you changing.

    Seeing as you stated, earlier, this was working, then come back and say it’s not working, what changed?

  • Hm, back again. Still problem. I have this error in apache error log:
    [Mon Aug 08 12:35:09 2016] [error] [client] PHP Fatal error: Uncaught exception ‘Exception’ with message 'Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 108, Message: ftp_login(): Login incorrect., H$
    [Mon Aug 08 12:35:12 2016] [error] [client] PHP Warning: ftp_login(): Login incorrect. in /var/www/html/fog/lib/fog/fogftp.class.php on line 108

    I have set fog user password with command passwd fog and it does not help. This worked last time I did an capture task, some weeks age in then latest svn version. Now I am on RC7 and still a problem. I have not touched the server other than running the update svn procedure. Any suggestion how to solve this?

  • Moderator

    @pmonstad Most likely your FOG account had an incorrect password which the installer fixes with the info in /opt/fog/.fogsettings

    So as people have said, FTP issue.

  • I did an update today to RC7 and it now works again. Have no idea what caused the database error.

  • Senior Developer

    Deploy is not capture, therefore “Deploy works OK” has no relevance to the issue.

    What’s the apache error logs showing? What’s the capturing system displaying?

  • Moderator

    @pmonstad said in not possible to capture images, database connection error:

    Deploy works OK

    That still makes me think its an ftp issue. Really if its a database issue I would think the FOG console would have issues or … deploy may work since it only uses kernel parameters.

    I could see registration fail if there were database user account issues.

  • Deploy works OK

  • Moderator

    @pmonstad I know I’m being a type “A” person this AM, but can you confirm that you can log in from a windows pc to the fog server using FTP and the fog (linux user) account?

  • @george1421 I know this has been an issue and I ran passwd fog to reset the password. No effect

  • Moderator

    Can you confirm if the fog (linux user) account password is still consistent with what is defined in the FOG management GUI? (I’m guessing here) The error may be misleading in that its not really a database error, but the step before where the FOS engine logs into the FOG server via ftp and moves the image from the /images/dev to /images directory.


Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.