Group Snapins unreliable



  • 1.3.0-RC-4 SVN Revision: 5941

    Imaged 15 machines as a group, only 3 got their snapins as intended, one didn’t join domain or anything. Pushed out the snapins (deploy all snapins) separately to each machine and it worked.
    reimaged the machine that didn’t join and it worked so looks like groups are broken in terms of snapins.


  • Senior Developer

    Group snapins should properly deploy. Will be available for RC-5.


  • Senior Developer

    @Wayne-Workman I can’t explain as join but I can confirm the snapins issue.


  • Moderator

    @ablohowiak said in Group Snapins unreliable:

    *I’m not really concerned about the domain join. That’s an infrequent occurrence.

    But fog cares.
    The client follows an order of operations, Domain comes before snapins.
    This is probably an AD Joining issue. @Joe-Schmitt :-)



  • Running Rc2…I added some hosts. Created a group to give them all the same settings. Added them to group…set the location, image, and snapins. Told group to deploy. Image went thru fine…but only 1 actually installed all snapins. Other 4 just sat there doing nothing. I then booted to pxe menu and picked deploy image…went thru perfectly. When I sent another group it did the same thing.

    So I then set the group, updated settings, then went to the machines and told them to deploy image from pxe menu…worked. but if deploying from group…something breaks.



  • @Tom-Elliott

    Yes - all snapins were applied via the group object and then should have applied after imaging was complete (deploy image and all snapins). When the machines did not receive any snapins an hour after imaging I checked the objects and they did indeed have the correct snapins associated. Then I went back to the group object and ran a new task (deploy all snapins) to the group and left for the day. 2 machines received their snapins after that and the rest were sitting in the task queue on the server doing nothing. When I deleted the tasks that weren’t running and (deploy all snapins) on each individual machine they worked… but they didn’t work reliably via the group object


  • Senior Developer

    This doesn’t make sense.

    Did you associate the snapins to all hosts? Or did you just tell the group to do a snapins type tasking?

    Taskings of snapin types will only apply to hosts that HAVE snapins associated to them.



  • @ITSolutions

    *I’m not really concerned about the domain join. That’s an infrequent occurrence.

    • The snapins did appear in the tasks que.


    ---------------------------------SnapinClient---------------------------------

    7/29/2016 7:33 AM Client-Info Client Version: 0.11.4
    7/29/2016 7:33 AM Client-Info Client OS: Windows
    7/29/2016 7:33 AM Client-Info Server Version: 1.3.0-RC-4
    7/29/2016 7:33 AM Middleware::Response No snapins

    • Windows 7 client, Ubuntu 14.04.4 for the server.

  • Testers

    *Did you check the client log on the machine that didn’t join the domain? Domain joining is completely separate from snapins, that doesn’t even need to be pushed it is a check every time the client connects.

    *Did the snapins appear in the tasks que on the server?

    *Also did you check any of the client logs of those hosts to see why snapins where not deploying?

    *What OS are you using, both on the server and client. Very hard to troubleshoot and correct bugs without information.


  • Moderator

    Were all the snapins associated before imaging was started? If they were, they auto-schedule themselves to deploy when the hosts come online. Did you doublecheck that snapin tasks were created in task management ?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.