HostnameChanger Hostname is correct



  • I’m having the same problem as this: HostNameChanger says hostname is correct

    Running Version 1.3.0-RC-1
    SVN Revision: 5936
    

    Ubuntu 14.04

    I added a bunch of new clients and imaged them last night. Identical hardware and images to what I already have in the lab. The log says:

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     2016/07/14 08:19 PM Client-Info Client Version: 0.11.3
     2016/07/14 08:19 PM Client-Info Client OS:      Windows
     2016/07/14 08:19 PM Client-Info Server Version: 8595
     2016/07/14 08:19 PM Middleware::Response Success
     2016/07/14 08:19 PM HostnameChanger Checking Hostname
     2016/07/14 08:19 PM HostnameChanger Hostname is correct
    ------------------------------------------------------------------------------
    

    But the hostname stays something like username-randomnumber.

    Output of http://lab2-server.ee.sun.ac.za/fog/service/ipxe/boot.php?mac=problematicmac:

    #!ipxe
    set fog-ip my.fog.server.ip
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    sanboot --no-describe --drive 0x80
    

    I can log in as the local user and join the domain manually.


  • Moderator

    @dolf The one marked as the answer. We keep the FOG Client article updated, because it’s important.



  • In @Joe-Schmitt’s second last message, the plan was to require no modification to setupcomplete.cmd. But the wiki still says I have to modify it. Which instructions should I follow?


  • Senior Developer

    v0.11.5 of the client prevents premature startups of the service. You will still need to disable the client before syprepping and restart the computer when sysprep is complete though (as described in the updated FOG Client wiki article).


  • Senior Developer

    The v0.11.5 release candidate should be sysprep compatible with no modification to the service or setupcomplete.cmd. More testing needs to occur before I confirm this though.


  • Senior Developer

    Even the legacy client had the same race condition, it just took so long to startup that people almost never encountered it.

    I’m doing my best to make the client automatically detect an ongoing sysprep action and then halt itself until sysprep is done. However, its slow work and is a very complex system to try and tap into. So no promises there.



  • Thanks. Makes sense. Will fix my stuff.


  • Moderator

    @dolf said in HostnameChanger Hostname is correct:

    I just installed the FOG Client without any further configuration, and it works for all PCs which were added to the FOG db last year.

    It’s a race condition. You were playing with fire and got lucky until now.


  • Senior Developer

    Without disabling the client you create a race condition. Race conditions can produce results that make no sense without knowing its a race condition.



  • @Joe-Schmitt Will do!

    Any idea why it would work for the old PCs but not the new ones? It find it strange.


  • Senior Developer

    @dolf if you can, after you update your image could you try deployments with early hostname changer both on and off? If I’m right the issues that early hostname changer had with sysprep should have been fixed.



  • Ooh… Didn’t know that. My setupcomplete.cmd only deletes the unattend.xml file. I have nothing that touches the FOG Client in any way. Looks like I’ll have to change the image, then? I just installed the FOG Client without any further configuration, and it works for all PCs which were added to the FOG db last year.


  • Moderator

    In addition to what Joe said,

    You have to disable the fog service before capture, and create a setupcomplete.cmd file that re-enables it and turns it on, and then capture your image.

    Early Hostname Changer must also be off for this to work right.

    details:
    https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep


  • Senior Developer

    @dolf If you are sysprepping is the client disabled on startup and then re-enabled in setup complete?



  • Yes I am sysprepping. If I deploy the same image to a PC that was in my FOG db before, it works. The new PCs are also identical hardware to the ones we already had (Dell Optiplex 990 USFF). If I deploy to one of the new PCs, it doesn’t join the domain. One some of them (about 10%, at random) the hostname changes, but it never joins the domain.

    I’ve been running around, joining them manually today because it was urgent… :)

    I don’t know what “early hostname changer” is.


  • Senior Developer

    This indicates something is tampering with the hostname and screwing it up. Are you sysprepping your image? Is early hostname changer enabled?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.