HostNameChanger says hostname is correct



  • I’m running server 6751 on Lubuntu 14.04 32 bit and client 0.9.11 on Windows 10 x64 machines in a simple workgroup.

    After image deployment all hosts retained the name of the host stored in the image, not the host name shown in FOG server. The client log shows:

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     3/20/2016 9:49 AM Client-Info Version: 0.9.11
     3/20/2016 9:49 AM HostnameChanger Running...
     3/20/2016 9:49 AM Middleware::Communication URL: http://fog-server/fog/service/servicemodule-active.php?moduleid=hostnamechanger&mac=A8:A7:95:93:72:87|AA:A7:95:93:72:87|DC:FE:07:06:58:38||00:00:00:00:00:00:00:E0&newService=1
     3/20/2016 9:49 AM Middleware::Communication Response: Success
     3/20/2016 9:49 AM Middleware::Communication URL: http://fog-server/fog/service/hostname.php?moduleid=hostnamechanger&mac=A8:A7:95:93:72:87|AA:A7:95:93:72:87|DC:FE:07:06:58:38||00:00:00:00:00:00:00:E0&newService=1
     3/20/2016 9:49 AM Middleware::Communication Response: Success
     3/20/2016 9:49 AM HostnameChanger Checking Hostname
     3/20/2016 9:49 AM HostnameChanger Hostname is correct
    ------------------------------------------------------------------------------
    
    

    I’m new to FOG, so I suspect operator error, but I’ve not been able to figure out what I’m missing.

    Any help is appreciated.

    Jerry


  • Developer

    @jfath Have you tried updating to the latest version and tested again? Please let us know!


  • Developer

    @jfath To see the changes Tom made you probably need to update to the latest version and re-run the installer. Would be great if you can confirm if things are working or not.


  • Senior Developer

    @jfath They’ve already been made. Just need a test to confirm if you would like please?

    Of course there is no requirement, but would be good to know.



  • Thanks Tom.

    Not a huge problem for me as I can just change the host names manually on a dozen or so machines. I’ll be happy to test any changes you make.

    Jerry


  • Senior Developer

    I’m 100% certain that this is not the case of your issues. Your being logged in has no impact on how the hostname changing operates.

    I have, however, found that many different key’s are used even if the “windows path” is the same. Linux, being case sensitive and all, is changing the keys, and most likely the client is checking the very same keys. Those keys are being updated, but it’s not the keys that the main windows system is actually looking at for the display of the names.

    I’m updating the init’s in hopes to better approach this, but I really don’t know.



  • It occurs to me that I’m logging in to the machines running client using a user account that does not have admin rights. Any chance that is keeping the hostname check/set from happening correctly? I’m not on site right now, so I can’t do the simple test of logging in as an admin.

    Jerry



  • http://10.0.0.4/fog/service/ipxe/boot.php?mac0=A8:A7:95:93:72:87 -> Host is NOT registered

    http://10.0.0.4/fog/service/ipxe/boot.php?mac0=A8:A7:95:93:72:87&mac1=AA:A7:95:93:72:87&mac2=DC:FE:07:06:58:38 -> Host is registered as EBGC-001

    http://10.0.0.4/fog/service/ipxe/boot.php?mac0=00:00:00:00:00:00:00:E0 -> Host is NOT registered

    The hostname listed for DC:FE… does match what I set when I registered the host and what I see in the FOG host list, but locally that machine still displays the original hostname from the captured image.

    Thanks again.

    Jerry



  • @jfath

    http://10.0.0.4/fog/service/ipxe/boot.php?mac0=A8:A7:95:93:72:87

    and

    http://10.0.0.4/fog/service/ipxe/boot.php?mac0=A8:A7:95:93:72:87&mac1=AA:A7:95:93:72:87&mac2=DC:FE:07:06:58:38

    also:
    http://10.0.0.4/fog/service/ipxe/boot.php?mac0=00:00:00:00:00:00:00:E0

    See what name it says the host is registered as, or does it say the host is not registered? What we are doing here is manually passing MAC addresses to the boot.php mechanism, which generates iPXE boot scripts based on the MAC addresses given.



  • Only the DC:FE… address is an actual host. It was the source machine for the log file and does appear in my list of hosts. I also checked the MAC address of the FOG server and it does not match the other addresses from the log.

    The local host names do not match the FOG interface. All of the machines show the same Windows generated host name from the machine that was used to capture the image. In the FOG interface I have registered the hosts as ebgc-001, ebgc-002, …

    Thanks for the reply. Anything else I might check?

    Jerry



  • Can you check the actual hostname on the computer and compare it against the hostname set in the web interface? Maybe they are the same? Do you know that by default, fog attempts renaming during imaging?



  • @jfath Can you search for each of those MAC address in the fog interface? Right in Host Management, there is a search option. Here are the MACs:

    A8:A7:95:93:72:87
    AA:A7:95:93:72:87
    DC:FE:07:06:58:38
    00:00:00:00:00:00:00:E0

    Not sure why that last one is all 0s and so long… Search for each one of these and see what you find.


 

412
Online

41.6k
Users

12.1k
Topics

114.2k
Posts