• When our Dell Optiplex 780 with Windows 7 is imaging, the host monitor shows as green.
    After it boots the status is red.
    Imaging and pings to the IP address, FQDN, or hostname of the PCs work fine from the Fog server.
    Disabling the Windows Firewall allows it to be green again. I would like to run with it on if possible.
    I tried adding FogTray.exe to the allowed applications in Firewall, but as long as Windows Firewall is enabled, the status shows as red.

    It would be nice if I knew what I could add to the exceptions list or change to get it working correctly.

    Anybody solve this?

  • Not sure if you ever resolved this issue, but after dealing with it myself I decided to document it in the wiki: [url]http://www.fogproject.org/wiki/index.php/Troubleshooting_Host_Management_Showing_Hosts_as_Down[/url]

  • Hmm, the only time i had the (!) was when i imaged the Windows 7 machine before i finished the host name and time setup (Fresh from Dell laptop, its the finalizing the windows setup). After i named the host proper and booted into windows, it went to just the red bubble.

  • I have noticed however, that most of the time when my Windows 7 hosts are ‘up’. The icon shows the red bubble with an exclamation point in it. Not just the red bubble signaling host is down.

  • I too am having this issue. It is a Windows 7 Dell Latitude e5420. I have spent a few hours smashing my head against this. During 1 of my 100s of google searches, i did find a post from someone saying this only effects Windows 7 PCs it seems. I am still testing this so i have not been able to use this on an XP machine yet. i opened every possible thing i could to the Windows firewall to allow ICMP, UDP, and TCP through both inbound and outbound connections. No dice. Only disabling the firewall would allow it to connect. UAC wasnt a factor.

    I eventually fired up Wireshark to see what was going on. With the firewall off, i can see the reply going out from Windows 7 laptop to the FOG server over UDP with the destination port of echo(7). With the firewall on, ICMP, UDP, and TCP open on both inbound and outbound, this packet is never sent.

  • ^^-----Opening port 7 UDP inbound on my windows machines doesn’t work as stated. . Like Mark says the only time I see a Windows 7 host as ‘up’ is when it hasn’t booted to windows and the firewall has been started.

  • FOG doesn’t use the standard ping (something about execution overhead being too costly), instead it uses UDP echo port (port 7) to get a response from the client. So if you’re making firewall exceptions for FOG to ping your clients you’ll want to check UDP 7.

  • Must be something else, as it did not help. The Fog server can ping the PCs just fine manually from Unix. I added the rule to the PCs with all protocols V4, but no difference. It must be something after the ping. I added FogService.exe to the allowed applications in the Firewall, but still no difference. Perhaps I need to add something in Win 7 to the Domain controller? It is odd that with the firewall off, and the domain administrator logged in, the status is green, but with the firewall off and other domain users logged in it is still goes red.

  • Developer

    you need to setup a ICMP Rule (Solution 2) - [url]http://www.sysprobs.com/enable-ping-reply-windows-7[/url]