Fog not auto joining to the domain requires additional restart to join-Windows 10



  • I think that there might be a bug with Fog auto joining computers to the domain right after imaging with Windows 10. I have two independent Fog systems one with the Fog client version 11.0 running Fog version 8179. The other Fog system is running the newest Fog client 11.3. I have notice with both, after deploying a Windows 10 image, it will not join to the domain, but if I restart the PC then it will join to the domain. I don’t know if it is something with the Fog client and Windows 10 or another issue that requires a second restart of the PC to join to the domain.



  • alt text


  • Moderator

    @x23piracy said in Fog not auto joining to the domain requires additional restart to join-Windows 10:

    Hi,
    here is the evidence that SetupComplete.cmd does not run with OEM:

    This has been added to the wiki previously, here:
    https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep



  • @Tom-Elliott said in Fog not auto joining to the domain requires additional restart to join-Windows 10:

    @Wayne-Workman for Windows 10.

    no that should be the case since windows 8!
    Look here: https://community.landesk.com/docs/DOC-33051

    With Windows 8 and Windows 8.1 Microsoft made a change to the sysprep environment to improve the end user experience by skipping the SetupComplete.cmd section if an OEM license is detected. This allows the end user to get to the Welcome Screen faster. This is what causes provisioning to fail to start after the reboot.

    My opinion? What a Bullshit, why not an option to enable it? Well they like to force business to enterprise section also by license reimaging oem is forbidden just FYI.

    Regards X23



  • @Wayne-Workman said in Fog not auto joining to the domain requires additional restart to join-Windows 10:

    #wiki worthy

    setupcomplete.cmd doesn’t run on OEM licensed hosts.

    not even only this also that:
    https://forums.fogproject.org/post/74436

    Regards X23


  • Senior Developer

    @Wayne-Workman for Windows 10.


  • Moderator

    wiki worthy

    setupcomplete.cmd doesn’t run on OEM licensed hosts.



  • @Tom-Elliott Thank You


  • Senior Developer

    @x23piracy I’ve edited the source for the “enforce” option so it will display what the current selection is. If there is no selection, it will be unchecked. If there is a selection it will be checked. This will be available for RC 2.



  • Hi,

    i could finally fix my non working SetupComplete.cmd for Windows 10 OEM.
    To get the SetupComplete.cmd being executed i use the unattend.xml section FirstLogonCommmands:

    <SynchronousCommand wcm:action="add">
    <Description>SetupComplete</Description>
    <Order>1</Order>
    <CommandLine>C:\Windows\Setup\Scripts\SetupComplete.cmd</CommandLine>
    <RequiresUserInput>false</RequiresUserInput>
    </SynchronousCommand>
    

    To get sure this is done automatically i allow autologon of a local admin once:

    <AutoLogon>
    <Password>
    <Value>password</Value>
    <PlainText>true</PlainText>
    </Password>
    <Enabled>true</Enabled>
    <LogonCount>1</LogonCount>
    <Username>username</Username>
    </AutoLogon>
    

    This will then execute the SetupComplete.xml while first login:

    del C:\Windows\System32\Sysprep\unattend.xml
    sc config FOGService start= auto
    net start FOGService
    

    Regards X23


  • Senior Developer

    @x23piracy It’s just how it is for now. Simple enough to fix, but not deeply impacting currently. Just understand, if you uncheck it and save it means you’ve unset that field, and the host will not perform those actions.



  • @Tom-Elliott said in Fog not auto joining to the domain requires additional restart to join-Windows 10:

    @x23piracy update the host first. That checkbox is imperfect as it attempts to set itself based on the host. If he host isn’t set it looks at what the default value is. My guess the default value is on, but the host value is 0.

    When i uncheck the option and update, it will be checked again. I think we had this in the past with some other option as a little bug.
    Means, i uncheck, click update, popup tells option saved and then the checkbox is checked again while i unchecked it. hmmm funny… :)

    I also tried to change this option for other hosts, it works no where, can you check for bug please?

    How to find out if this option is set or not for a particular host when the webif always rechecks the checkbox?

    Regards X23


  • Senior Developer

    @x23piracy update the host first. That checkbox is imperfect as it attempts to set itself based on the host. If he host isn’t set it looks at what the default value is. My guess the default value is on, but the host value is 0.



  • @Tom-Elliott that option was enabled but does not rename hostname while logged on:

    alt text

    is this maybe the problem?

    alt text

    Regards X23


  • Senior Developer

    @x23piracy In the GUI under Active Directory, there’s a checkbox under the password legacy field.



  • @Tom-Elliott i tried the method with firstlogon command and this seems to work but i need to enforce hostname change, can someone tell me how to force this?

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     22.07.2016 11:52 Client-Info Client Version: 0.11.4
     22.07.2016 11:52 Client-Info Client OS:      Windows
     22.07.2016 11:52 Client-Info Server Version: 1.3.0-RC-1
     22.07.2016 11:52 Middleware::Response Success
     22.07.2016 11:52 HostnameChanger Users still logged in and enforce is disabled, delaying any further actions
    ------------------------------------------------------------------------------
    

    I need to force this, else i need to logoff manually.
    My idea is also to use unattend.xml for 1 auto logon, but i need hostname change forced else i need to logoff manual.

    Regards X23


  • Senior Developer

    @x23piracy What I meant is my windows 10 image is not sysprepped, so the setupcomplete.cmd isn’t even a thought. My windows 7 worked, which I’m guessing is the same for you.

    I suppose, one approach, to get the “setupcomplete.cmd” effects with OEM and Windows 10 would be to have the machine auto login one time. In the Audit mode layout, add a startup script that calls your setup complete script. Once the setupcomplete is done, have the startup script delete itself as well. Then when the system finishes setup, it should login to the administrator prompt, and perform the actions you have defined in the startup script.

    This is theory, I don’t know how feasible such a setup would actually be though. The nicety that was setupcomplete.cmd is the explorer wasn’t started until after the setupcomplete completed its tasks, which shortly after would be rebooted due to the re-enabling of the FOG Client. Using the “startup script” method would mean the administrator login is fully accessible.



  • Hi,

    here is the evidence that SetupComplete.cmd does not run with OEM:

    alt text

    https://community.landesk.com/docs/DOC-33051

    alt text

    Regards X23



  • @Tom-Elliott how could it run if you are not using sysprep?


  • Senior Developer

    Of course I’m not doing sysprep for Windows 10 yet.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.