How To Acquire New Kernels?



  • Hello… This may seem like a dumb question, but with FOG 1.2.0, when I go to the Kernel Update page, the only available “Published” kernels date from last year. July 2015 is the most recent. How does one go about updating this list? I can see from the fogproject.org/kernels site that there are newer versions available. That’s great. But I need to make them available locally. The July 2015 kernel is not working with our
    newly purchased Optiplex computers (7440s).

    We are otherwise extremely pleased with all the great work the FOG team has done. Our school district has used this imaging solution for years.

    Thanks. --PeterT, July 12, 2016


  • Moderator

    @PeterT Just to circle back on the question.

    I just received a 7440 AIO and using FOG 1.3.0-RC8 I was able to deploy to the 7440s without making any adjustments to the device. I just unboxed it, plugged it in and pxe booted into the fog menu… and the rest they say is history.


  • Moderator

    @PeterT said in How To Acquire New Kernels?:

    I suppose the next version of FOG might automatically update storage nodes along with the master node, but now that we figured it out, we don’t mind doing it ourselves.

    I’m actually actively working on this. In the future, if PKI authentication is setup for the Main server to all storage nodes (one way), then when running the installer on the main, you’ll have the option to update all nodes at once as well. I’m working on making it easy - there’s a lot involved, and I’m almost done with it.


  • Moderator

    @PeterT Thanks for providing the feedback on this issue.

    As for the master node updating the storage nodes, that is not a bad idea. You should post a feature request for that function. I probably could be handled with the replicator service on the master node (speaking off the top of my head). That feature would create a consistent FOS boot environment across all of the storage nodes.



  • @george1421 Hello… Problem SOLVED. It turns out the newest kernel that is easily made available using FOG version 1.2.0 works just fine with the new Dell OptiPlex 7440 all-in-one desktops. To be specific, that would be kernel 4.1.2.64.

    Our problem arose because we use storage nodes in our various locations and almost all of our imaging uses one of them, not the master.

    So while the master node was updated, using the FOG configuration kernel update utility, local nodes were still using older versions of bzImage. To get things working, I needed to log into the local node and quickly wget the correct kernel. I figured this out when I set one client to use the master node for imaging instead of the normal local node and the process completed normally.

    I suppose the next version of FOG might automatically update storage nodes along with the master node, but now that we figured it out, we don’t mind doing it ourselves.

    Thanks for your time and attention. This thread can be closed as “Solved” (but I don’t know how to do that.)

    –Peter


  • Moderator

    @PeterT You have to excuse me because I’m reading too many threads here.

    You have a 7040 and its failing the compatibility test…

    1. What part of compatibility is it failing? (disk??)
    2. What firmware version are you running on these 7040 AOI (I can say I had to update the firmware on the 7040 SFF to 1.4.4 to make them happy to uefi boot).
    3. Do these AOIs have HDD, SSD, or NVMe disks.
    4. (and most important) What version of FOG are you running? (hint: look at the numbers near the cloud on the web management gui)


  • @george1421 Hello… I tried the compatability test an the Optiplex 7440 all-in-one and it said it was not compatible. That’s what started my quest for an updated kernel. I tried the newest bzImage (July 11, 2016), but it didn’t work. It gets to the point where it almost starts imaging, then the screen goes black and the cursor blinks away in the lower left corner. Ironically, the system registered with FOG with no problem, and it recognizes it needs to start the imaging task. So the network communication seems okay. Possibly something a kernel option setting might correct. Thanks. --Peter


  • Moderator

    @PeterT I know for sure the 7440, 7240, 7470, and 7270 work with the current kernels. When you select the compatibility testing from the FOG iPXE menu what does it report for both hard drive and network.


  • Moderator



  • Hello… I followed the directions to obtain the newest kernel and replaced my bzImage files, so thanks for sending along clear directions for doing so. We did not have much luck getting it to work with a Dell Optiplex 7440, but that’s another thread. At least we know we are working an up-to-date bzImage. Thanks for your help. --PeterT


  • Moderator

    The mods have a secret location where we can get the latest kernels. I’ll let you in on the secret if you promise to not share it with the world.

    You can manually download the latest kernels for the trunk version (also will work for 1.2.0 stable) from these urls (that you already found).

    https://fogproject.org/kernels/bzImage
    https://fogproject.org/kernels/bzImage32

    Just download these files directly on your fog server using the wget command (assuming your fog server has internet access) and then do the following.

    1. Change to the following directory: /var/www/html/fog/service/ipxe
    2. Rename bzImage and bzImage32 that already exist in that directory
    3. Copy the above downloaded files into that directory.
    4. Done.

    These steps do require you to have linux console access.


  • Moderator

    @PeterT Not sure, but I think that the better way is to update to latest SVN/Trunk version. You’ll have all new kernel update and features.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.