SOLVED Capturing NTFS Filesystem Resize on Build 8215 w/Kernel 4.6.2 on CentOS 7.2.1511

  • It appears I’ve run into a ‘Resizing Filesystem’ problem on an ntfs disk Hyper-V 2012 R2 VM I’m trying to upload.

    A half hour later and I’m still waiting on `Resizing Filesystem …’ to complete.

    This is with Kernel 4.6.2 . I’m going to pop this one and start reverting kernels to see if I get some love.

  • @Tom-Elliott Sorry for the delay… patch week and all that fun.

    I ran with disabling dynamic memory for other VMs until today. I updated my dev server to build 8597 and kept the 4.6.2 that the installer downloaded today (2016/07/14) and the issue appears resolved.

  • Can we get an update on this?

  • I’ve updated kernels to have the patch I made for this a while ago. I’ve not made it in the original 4.6.2 kernels (and possibly some other files). I don’t know if this is a suitable fix, but maybe it could help.

  • Moderator

    @sudburr Well you should know about this, shouldn’t you?!?

    @jkozee Any news on that issue yet? Did you ever get an answer from the kernel devs?

  • I believe this is a dynamic memory issue. Disable dynamic memory in hyper-v and the newer kernels work. The 64 bit kernels also seem to work even with dynamic memory on.

  • 4.5.3 also hangs.

    Reading past conversations regarding similar issues, I rolled back to Kernels 4.1.4 and resizing now works in seconds.