Chainloading failure: Toshiba Tecra C40-C UEFI & Samsung SSD MZNLF128HCHP-000



  • I am attempting to image 100 new Toshiba Tecra C40-C computers running Windows 10.

    They have UEFI based systems and SSDs. The SSD is an M.2 Samsung MZNLF128HCHP-00.

    I am able to iPXE and get to the Fog menu and register the computers. However, they will not boot back to the SSD but says “chainloading failure.”

    Also, I am able to schedule a task and begin uploading an image but that fails at the end, too.

    I began using Fog in September and have successfully imaged many machines in legacy mode or BIOS with no trouble but this is a real problem.

    I need to figure this out because we need all of these computers by August 1st.

    Thank you for your help,
    Melissa


  • Moderator

    @mabarton I briefly went over this thread because it’s been a while. Have you individually tried every EFI exit type?



  • @george1421 I’m working on this.
    rEFInd would not install correctly. I am troubleshooting it now.



  • @george1421 I still have the chainloading failure. You’re right, I have been on vacation. When I am back, I will run the commands you gave me to see if it picks up the M.2. I appreciate the help.


  • Moderator

    @Sebastian-Roth Unless the OP has an update, the answer is not yet. Capture and deploy work to these machines. What is failing still is exiting out of the iPXE menu to boot to the SSD. This is failing. The USA folks typically take this week as a summer break so the OP may be on holiday and will report back next week. The unlucky ones like me still work this week. ;-(


  • Developer

    @george1421, @Wayne-Workman Sorry, I’m just being a bit lazy after having been offline (visiting a friend in the mountains) for almost a week I am trying to catch up… Is this solved or are we still seeing an issue with this laptops?


  • Moderator

    @mabarton If the default out of the box refind.conf does not work look for a line like this one ( of course the next time you work, and not on your free time).

    scanfor internal
    

    This tell refind where to look for bootable devices. You may want to append/change that line to search in a few more places, like this one.

    scanfor internal,hdbios
    

    IF that doesn’t work then extend the search a bit more (reminder you need to reboot the target after each change.

    scanfor internal,external,hdbios,biosexternal
    

    One of those should pick up that M.2 disk. (said with some hope) We are walking on some uncharted ground here so there will be many trial and error tests until we get it right (or just give up ;-) )

    ref: http://www.rodsbooks.com/efi-bootloaders/refind.html



  • @george1421 it has deployed beautifully-- with the exception of the boot looping:)

    I am working in the rEFInd, so we shall see if it works.

    Thank you for the support!


  • Moderator

    @mabarton Sorry I’ve been out enjoying the holiday. So image deployment worked, you are able to clone your image to 2 or more target systems right?

    The next bit you need to work on is the pxe exit mode stuff (if you want to). Just to recap you’ve selected all of the exit modes for UEFI Exit and none worked. Building on what Tom posted rEFInd should work. While I don’t have personal experience with this issue (yet), if rEFInd does not work out of the box (should be near the end of the list of options). There is a configuration file on the fog server that may need to be tweaked (refind.conf). Its located in /var/www/html/fog/service/ipxe on the fog server. We may need to add additional resources to look for (using the scanfor tag).



  • @Tom-Elliott I fear that I would not be much help, but I rarely give up!

    The deployment worked!!! I think I am going to have a party to celebrate the end of an entire week of battling this problem. I may be able to leave the school at a decent hour next week!! If it were not for this forum and all of your help, I don’t know what I would have done.

    Thank you, thank you, thank you, Tom, Wayne, and George. Your help and expertise have been immensely appreciated!


  • Senior Developer

    @mabarton don’t lack on sharing what you find. That way, maybe, I could provide a usable Config for all. After all open source is all about contributing. It sounds selfish I suppose but I would, and possibly many others, be most appreciative of yours, or anybody else’s, findings on this.



  • @Tom-Elliott Our computers go out to students living anywhere in Kansas, so I don’t get to use all of the benefits of Fog. Since the computers are not in my area, I always shut off PXE boot. Our brick-and-mortar uses iPads, primarily.

    However, our school belongs to a network of schools called “Teen” and I am hoping to introduce Fog to those schools and a few others in our area. This is Kansas after all, and they don’t like giving schools money.

    @Tom-Elliott said in Chainloading failure: Toshiba Tecra C40-C UEFI & Samsung SSD MZNLF128HCHP-000:

    @mabarton I think, however, this would be the perfect time to learn how to configure rEFInd to enable booting to actually happen without a problem.

    I am googling that now.


  • Senior Developer

    @mabarton when setting up the task there is a place it asks you to shutdown after imaging.


  • Senior Developer

    @mabarton the chainloading IS a problem but I don’t have a way to fix it for now, so it is also a nuisance as it means, at least for this systems having issues, they won’t automatically perform tasks you might need. I think, however, this would be the perfect time to learn how to configure rEFInd to enable booting to actually happen without a problem.



  • @mabarton So, is there a way that I can force the computers to shut down after the imaging process is complete? I am going to deploy this image to 100 computer and I don’t want them to boot loop until I get back to work.



  • @Tom-Elliott
    That is excellent news! All of the other computers I have imaged with Fog have been legacy and HDD, and all of their images were almost the same size as the drive. That was why I was so concerned with the size/chainloading error.

    Thank you, Tom. So, the chainloading error is more of a nuisance than a problem.?


  • Senior Developer

    @mabarton booting and imaging are two completely separate things. The size is more a convenience thing to let you know how big of a hard disk you’ll need. I suspect, however, simply disabling network boot after imaging is complete will allow the system to boot properly.



  • @mabarton So, I am looking at the image of a 128gb SSD and it shows that the image is 460 mib. I am going to deploy this image to see what happens.

    My concern is that the chainloading error means that Fog is not able to boot the SSD and so it is imaging something else???


  • Moderator

    @mabarton Well, that just means it’s empty.



  • @Wayne-Workman I use sudo su and sudo -i, but I have never used /root because when I use ls I see nothing in /root.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.