Trunk install, fog.conf vhost file issue



  • Hi,

    Not sure what this, perhaps an installer bug?

    Fresh install Fedora 23. Version 8179.

    During the install script this appears:

     What type of installation would you like to do? [N/s (Normal/Storage)] n
     grep: 2601:243:200:d722::73a8: No such file or directory
     grep: 2601:243:200:d722:d685:64ff:fe01:6a05: No such file or directory
    
     Would you like DHCP to handle DNS? [Y/n]
    

    The installer keeps running, but bombs out when restarting Apache. Systemctl status httpd indicates that the fog.conf file has some ill-formatted strings:

    <VirtualHost *:80>        #RewriteEngine On
    
        KeepAlive Off
        ServerName 192.168.1.251
    2601:243:200:d722::73a8
    2601:243:200:d722:d685:64ff:fe01:6a05
        DocumentRoot /var/www/html/
        #RewriteEngine On
        #RewriteRule /management/other/ca.cert.der$ - [L]
        #RewriteRule /management/ https://%{HTTP_HOST}%{REQUEST_URI}%{QUERY_STR$
    </VirtualHost>
    <VirtualHost *:443>
        KeepAlive Off
        Servername 192.168.1.251
    2601:243:200:d722::73a8
    2601:243:200:d722:d685:64ff:fe01:6a05
        DocumentRoot /var/www/html/
    .....
    

    -kurt



  • @Tom-Elliott Hi - I just ran into the same problem. I’ll go ahead disable ipv6 but thought I’d let you know the development installer grabbed from github still seems to try to include ipv6 in fog.conf


  • Senior Developer

    I’m pretty sure I’ve added the code buts to only worry about IPv4 but could use confirmation of this.


  • Moderator

    @Sebastian-Roth I think the installer should ignore IPv6 addresses.


  • Developer

    Not sure if we should still change the installer script to ignore those IPv6 addresses… @Developers ?


  • Moderator

    @kurtblah probably. And there isn’t the man power to do an overhaul on that. IPV6 will have to wait for the 2.0 rewrite.



  • Disabling IPv6 did the trick. I ran:

     sudo echo "1" > /proc/sys/net/ipv6/conf/all/disable_ipv6
    

    and the installer ran normally. I’ll need to shut it down permanently.

    Thank you for your help. Is this IPv6 issue consistent in all of the builds?

    -kurt


  • Moderator

    @kurtblah So, do you need IPv6 on this system for some reason?

    If not, here’s instructions to turn it off for you:

    backup interface config:
    cp /etc/sysconfig/network-scripts/ifcfg-enp1s0 /etc/sysconfig/network-scripts/ifcfg-enp1s0.old

    Edit the interface config:
    vi /etc/sysconfig/network-scripts/ifcfg-enp1s0

    Change these lines to off or zero or no:

    NETWORKING_IPV6=no
    IPV6INIT=no
    

    If the lines are not there, you can try to add them.

    Restart the interface - this command is sorta dangerous if the node is far away and the config is bad, the interface could fail to come back up, so keep that in mind:

    ifdown enp1s0;ifup enp1s0

    After doing this, try to re-run the fog installer and see what happens. Hopefully it works.

    To put the old config file back if you want:

    rm -f /etc/sysconfig/network-scripts/ifcfg-enp1s0
    cp /etc/sysconfig/network-scripts/ifcfg-enp1s0.old /etc/sysconfig/network-scripts/ifcfg-enp1s0
    ifdown enp1s0;ifup enp1s0
    

    Reference:
    http://linoxide.com/linux-how-to/disable-ipv6-centos-fedora-rhel/

    Noteworthy:
    http://tecadmin.net/disable-ipv6-on-linux/#
    https://www.g-loaded.eu/2008/05/12/how-to-disable-ipv6-in-fedora-and-centos/



  • no problem. here’s the ip addr:

    [root@localhost bin]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether d4:85:64:01:6a:05 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.251/24 brd 192.168.1.255 scope global enp1s0
           valid_lft forever preferred_lft forever
        inet6 2601:243:200:d722::73a8/128 scope global dynamic
           valid_lft 592005sec preferred_lft 592005sec
        inet6 2601:243:200:d722:d685:64ff:fe01:6a05/64 scope global noprefixroute dynamic
           valid_lft 226861sec preferred_lft 226861sec
        inet6 fe80::d685:64ff:fe01:6a05/64 scope link
           valid_lft forever preferred_lft forever

  • Moderator

    @kurtblah Sorry for so many commands. I’m working through you like I would if I were there at the terminal.

    What is the output of this: ip addr show



  • [root@localhost bin]# systemctl restart httpd
    Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
    
    [root@localhost bin]# systemctl status httpd -l
    ● httpd.service - The Apache HTTP Server
       Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Mon 2016-06-20 19:23:42 CDT; 15s ago
      Process: 2975 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
     Main PID: 2975 (code=exited, status=1/FAILURE)
    
    Jun 20 19:23:42 localhost.localdomain systemd[1]: Starting The Apache HTTP Server...
    Jun 20 19:23:42 localhost.localdomain httpd[2975]: AH00526: Syntax error on line 4 of /etc/httpd/conf.d/fog.conf:
    Jun 20 19:23:42 localhost.localdomain httpd[2975]: Invalid command '2601:243:200:d722::73a8', perhaps misspelled or defined by a module not included in the server configuration
    Jun 20 19:23:42 localhost.localdomain systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE
    Jun 20 19:23:42 localhost.localdomain systemd[1]: Failed to start The Apache HTTP Server.
    Jun 20 19:23:42 localhost.localdomain systemd[1]: httpd.service: Unit entered failed state.
    Jun 20 19:23:42 localhost.localdomain systemd[1]: httpd.service: Failed with result 'exit-code'.```
    

    -kurt


  • Moderator

    @kurtblah Ok, so what happens when that file is left alone, and you run systemctl restart httpd and then systemctl status httpd -l



  • This is where the installer bombs out:

     * Setting up SSL FOG Server...................................OK
     * Restarting Apache2 for fog vhost............................Failed!


  • From what I can tell, the installer is adding lines to the fog.conf file that keeps the httpd service from restarting.

    I can take out the bad lines from the fog.conf file and the httpd service restarts as it should.

    -kurt



  • systemctl enable mariadb
    

    returns nothing. running the mysql command works fine.

    [root@localhost bin]# mysql
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 3
    Server version: 10.0.23-MariaDB MariaDB Server
    
    Copyright (c) 2000, 2015, Oracle, MariaDB Corporation Ab and others.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    MariaDB [(none)]> \q
    Bye
    

    The munged lines in the fog.conf vhost file and the installer output look to me like IPv6 addresses


  • Moderator

    @kurtblah what about systemctl enable mariadb ?



  • @Wayne-Workman

    [root@localhost ~]# systemctl enable mysqld
    Failed to execute operation: No such file or directory
    [root@localhost ~]# systemctl enable mysql
    Failed to execute operation: No such file or directory
    

    MariaDB is installed and works.


  • Moderator

    @kurtblah what happens if you manually run systemctl enable mysqld and systemctl enable mysql ?



  • getenforce --> permissive

    sestatus and firewalld status:

    [root@localhost ~]# sestatus
    SELinux status:                 enabled
    SELinuxfs mount:                /sys/fs/selinux
    SELinux root directory:         /etc/selinux
    Loaded policy name:             targeted
    Current mode:                   permissive
    Mode from config file:          permissive
    Policy MLS status:              enabled
    Policy deny_unknown status:     allowed
    
     [root@localhost ~]# systemctl status firewalld
    ● firewalld.service - firewalld - dynamic firewall daemon
       Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2016-06-20 16:04:33 CDT; 2h 7min ago
      Main PID: 750 (firewalld)
       CGroup: /system.slice/firewalld.service
           └─750 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid
    
    Jun 20 16:04:32 localhost.localdomain systemd[1]: Starting firewalld - dynamic firewall daemon...
     Jun 20 16:04:33 localhost.localdomain systemd[1]: Started firewalld - dynamic firewall daemon.

  • Moderator

    @kurtblah What is the output of getenforce and sestatus and systemctl status firewalld ?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.