Fog Web GUI Login Problem



  • We are in the process of upgrading our FOG Server. I installed Ubuntu Server 14.04.4 LTS, then installed FOG 1.2. I had started adding a few clients to test uploading/downloading images and I was kicked back to the login screen after a few minutes. When I try to login the screen refreshes the site and version number but does not login If I try an invalid password I get the message at the top of the screen informing me about an invalid password. I have not created any other users and was using the default FOG/password combination. I have tried resetting the default password in MySQL, alternate browsers/computers all with the same result.
    Any suggestions?



  • I was able to get it working. The problem turned out the be the server running out of storage, once that was fixed everything is working again.
    Thanks for the suggestions!


  • Developer

    Confirm this plz…

    mysql -u fog -p fog
    

    Then type in the password. Do you get…

    ERROR 1045 (28000): Access denied for user 'fog'@'localhost' (using password: YES)
    

    Just had a small hickup in svn 5680. Had to do the following…

    mysql> create user 'fog'@'localhost' identified by 'your password here';
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> GRANT ALL PRIVILEGES ON * . * TO 'fog'@'localhost';
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> FLUSH PRIVILEGES;
    

  • Moderator

    @dbrisser Try to restart mysql, and then apache. On ubuntu that should be service mysql restart;service apache2 restart



  • No, I didn’t capitalize fog. I don’t get the invalid login message at the top of the screen like I do if I would use Fog as the username.



  • Just to be clear, the default user name and password you were using were “fog” and “password”?

    Did you capitalize “fog” for the user name?


Log in to reply
 

397
Online

39210
Users

10856
Topics

103346
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.