PXE-M0F Fedora 23 server



  • The fog server issues IP address as the client machine then gets an ip address as per DHCP. The boot menu comes up press F8 for boot menu
    When I select boot from network I just receive boot server: X.X.X.X TFTP.
    PXE-M0F : Exiting Intel Boot Agent
    Selected boot device failed. Press any key to reboot the system



  • @george1421 my newbie mistake! this is now resolved


  • Moderator

    @purpleturtle99 I’m glad you got it going.

    Sorry for the 20 questions, but I knew something was going on that was not apparent.



  • @george1421 U r the man ! and yes it would make sense I stop the dnsmasq service and it worked 1st time.

    BTW on Fedora 23 server it refers you back to systemctl stop dnsmasq.service

    Quick reg all done


  • Moderator

    @george1421 If dnsmasq is not running…duh you included the LTSP file contents, you have dnsmasq running! Please stop that service. You only need that if your dhcp server can’t supply dhcp options 66 {boot server} and 67 {boot file}.


  • Moderator

    @Wayne-Workman That is exactly what I was thinking. The next step is to packet capture the dhcp process. I was trying to avoid that but I guess we need to go down that path.

    @purpleturtle99 Did you disable the dhcp server in the TL-MR4320 to ensure that the fog server is the only dhcp server on your network of 3 devices?

    also just for grins can you key this into your linux console service dnsmasq stop does it return that it was running?


  • Moderator

    @george1421 the menu in that screen shot I’m pretty sure comes from dnsmasq.

    If you have DHCP running on the fog server, you do not need dnsmasq.



  • @george1421 Plugged the WAG 120N back in to see if it is router related and got the same error message?



  • @george1421 it is running the firmware that it came with I haven’t mugged around with the firmware at all. OK let me explain. I used to have a Ubuntu flavor Fog server working with a Cisco/linksys wag120n and this combo worked like a dream for Win 7 boxes. Not so much for Win 8.1 and 10. As the company I work for are now starting to roll out Win 10. There fore I need a fog box that can make images for Win 10. Reading a bit up on the subject I decided to use Fedora 23 server with the TL-MR4320 and to do gigabyte interfaces. To speed up the image process up a bit.

    There is no device on the network for 192.168.1.20 and pings don’t work to 192.168.1.20 anyway. Basically the network is 1 X fog box(fedora 23 server) 1 X TP-Link router 1 X win 10 box


  • Moderator

    Stick with me here.

    The TL-MR3420 appears to be a home router kit (or SMB kit). Are you running the native firmware on that or are you using a third party firmware like ddwrt?

    Before you installed FOG what was issuing dhcp addresses for this subnet? Was it the TL-MR3420?

    And lastly what is device 192.168.1.20?



  • @george1421 Yes my Fog server is on 192.168.1.102, the default Gateway is a TP-Link TL-MR3420 router.
    This install centos 7 line in the boot menu bug me immensely. As my DHCP conf file and the LTSP .conf file does not refer to this at all.

    LTSP file:
    port=0
    log-dhcp
    enable-tftp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe.0,192.168.1.102
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-prompt=“Press F8 for boot menu”, 30
    pxe-service=X86PC, “Boot from network”, undionly
    pxe-service=X86PC, “Boot from local hard disk”, 0
    dhcp-range=192.168.1.102,proxy

    DHCP file:
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16; # RFC4578

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.1.102;

    subnet 192.168.1.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 192.168.1.5 192.168.1.20;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 192.168.1.102;
    option routers 192.168.1.1;
    filename “undionly.kkpxe”;
    }


  • Moderator

    @purpleturtle99

    Your dhcp server is 192.168.1.102, can we assume that is your FOG server?

    I see you have a default gateway setup as 192.168.1.1, what is that device (router I know, but mfg and model)?

    Well that is strange too, where does this boot centos 7 from network server 192.168.1.20 come from? And what is 192.168.1.20? (as you see it helps to have a picture)


  • Moderator

    ok can you post the contents of dhcpd.conf and a screen shot of the error?

    [edit] Oops I see you just posted a screen shot. Not very detailed of error.



  • I used the following:
    https://wiki.fogproject.org/wiki/index.php/Fedora_21_Server

    and get the error message as per attached screenshot

    https://www.dropbox.com/s/ngu4lxokblzzgyw/WP_20160614_001.jpg?dl=0

    and no other DHCP server/devices in the network



  • This post is deleted!

  • Moderator

    Well I can tell you PXE-M0F basically means the PXE rom said “Eh, I give up”. Is there any PXE-EXX code before that?

    So you have fog as the dhcp server for that imaging network. Is fog the only dhcp server on that subnet? What instructions did you use to setup the fog dhcp server?

    And lastly, please upload a screen shot of the error (with IP addresses). Sometimes a picture sends more information than just text.


Log in to reply
 

401
Online

39210
Users

10856
Topics

103346
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.