Replication not working - no log files on storage node



  • Replication is not working between my master server and a freshly installed storage node. There are no files in /opt/fog/log or /var/fog/log on the storage node, but the services start okay as far as I can tell.

    Another weird issue is the storage node is returning the string #!db when I go to http://storagenodeip/fog/service/getversion.php

    Both servers on newest git version 8038



  • @Tom-Elliott Replication now working beautifully. Thanks again Tom!


  • Senior Developer

    Moved thread to bug reports, hopefully replication will work now. Please keep us posted.


  • Senior Developer

    Found the storage group information wasn’t updating properly because of a mixed up id call. sorry about that.

    It’s been fixed for both Snapin and Image groups. Now hopefully the logic is still sound and will work with replication too.


  • Moderator

    @moses git pull --depth 1



  • @Tom-Elliott No, we replaced everything with CentOS (essentially just started fresh today).

    One thing I just noticed: when I ran git pull to update, it only pulled down something like 10 MB. When I just tried to update again using sudo git pull, there’s a ton more that needed to be synced…

    Going to let that do it’s thing and try again.


  • Senior Developer

    There’s your problem.

    Betcha the main server is a variant of Debian? (Ubuntu, Debian, Kali, etc…)

    If you edit the master server’s /etc/mysql/my.cnf (it changes so you have to find it) and comment the bind-address=127.0.0.1 and restart mariadb/mysql, does the service operate properly?


  • Moderator

    Are the master node and the storage node in the same storage group?

    FOG uses ftp to copy files from the master node to the storage node. Does the fog user account work (as defined in the storage node settings of the fog webgui) when you try to manually ftp connect (from your windows computer) to the storage node?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.