• Is anyone have a problem booting these laptops or should I be using a different kernal. The error message we get is unable to register due to these reasons attempting to send inventory and than it would just keep retrying and never register first time I have seen this all the other computers are no issue just the think pad laptops.

  • @Darrell-Lanson This normally presents itself on uploads by getting hung trying to create the partition table.

    We have utilities already that allow you to fix this really quite easily, but does require you load up in a debug mode.

  • So I fixed my issues with imaging the Lenovo E560 turns out even after imaging the drive has a GPT structure even though one isn’t present here are the steps I went through to fix it.

    1. Start Clonezilla
    2. Select cmd line
    3. Type in sudo gdisk /dev/sda
    4. (Press 1 to select MBR)
    5. Press ‘x’ and enter to reach the eXpert mode
    6. Now press ‘z’ to delete the gpt
    7. At this step be careful, you will get an option to blank out your MBR, do NOT do it. If you do you will need to install OS on the drive to rebuild MBR.
    8. Press Ctrl + C when ever you need to exit from gdisk.
    9. You will now be able to image this computer.
      Some of these steps I found online can’t seem to find where but this fixed my boot problems even after imaging I had both a MBR and GPT partition even though the GPT part didn’t actually exist.

  • @Tom-Elliott So I did a few things along the lines of your suggestion.

    • I took the drive from the laptop and threw it in the Dell workstation, imaged, no boot, put the drive back in laptop and still no boot (me thinks drive at this point)
    • Grabbed an SSD from an old laptop which I had imaged with Fog previously but laptop died (drive is fine), threw that in laptop and it imaged and booted like normal.

    The drive came with an operating system installed on it, but I suppose it could be bad. It’s a 512GB SanDisk X400.

    @george1421 I just load necessary drivers after booting, the Dell drivers are all generic device drivers that exist within Windows Update and it works without issue, Lenovo has a Software Update utility that is a 1 click run and all necessary drivers are downloaded and installed.

    Edit: Like I said I have an identical model coming this week which I will test on, could be an issue with the drive since I was able to image a different drive on the laptop, so it appears the laptop is functioning normally RE Fog compatibility.

  • Moderator

    @Shadow00Caster How do you “do drivers”? Are you using a post install script to inject the drivers after the image has been placed on the storage device?

    @Tom-Elliott is there a way to check the drive structure via the FOS engine? I know lsblk will show the disk structure and it can be aligned with the fog files in the images directory.

  • @Shadow00Caster I think the reverse and test would possibly work. Replace the Lenovo ssd with a spinner. Of course your way would be beneficial as well.

  • @Tom-Elliott No, it’s a 7200RPM drive, I could throw in an SSD and test, do you think that would make a diff?

  • @Shadow00Caster the system it booted fine to is also ssd?

  • @Tom-Elliott Before updating to 1.3.0, should I create a new image of using 1.3.0? Note that I just deployed this same image to a Dell workstation without issue (on 1.3.0) pxe booted, partcloned, rebooted into Windows 8.1 Pro.

    @george1421 I use a master image and then do drivers, never had any issue doing it this way and I have been using Fog for over 7 years. I will attempt the debug suggestion and reply with results.

  • @Tom-Elliott read fully sorry I see you are in trunk. Was this image created prior to updating or after?

  • @george1421 this sounds, most likely, it’s just 1.2.0. It simply isn’t setting the mbr boot portion properly, or its offset improperly. If I had to guess any further, I’m going to say it’s likely not setting the bootable partition as not active.

    If you can please try to update to trunk. I really think it will, at the very least, give your devices a more dynamic supporting layout.

  • Moderator

    @Shadow00Caster Thanks for the clarity here. Nothing is standing out as a possible issue.

    I wanted to make sure that the flashing cursor happens when bios is telling the machine to boot (which it is). We have see some issues with select the correct FOG exit mode for certain models, but that is not it in this case.

    I guess I have to ask how did do you create your master image? I’m thinking that it could be a sata driver issue or the image being placed on the disk is corrupt. My initial question is how to you inject drivers for each model of computer you deploy? Do you have a single golden image you deploy to every model (then inject the proper drivers) or do you create a model specific golden image and then deploy that?

    It would be interesting to know the results of this test. Setup a debug deployment to this target computer (hint: select the debug option when you schedule a deployment task). Then pxe boot the target system. You will be presented with a bunch of instructions then after a few enter presses you will be dropped at a command prompt (this is the command prompt of the FOS engine). At the command prompt key in lstblk /dev/sda and post the output here. (hint: if you give root a password on the FOS engine with passwd at the command prompt you can connect to the IP address of the FOS engine with putty (from your windows computer) to aid in screen shots and sunch)

  • @george1421 Questions answered in order:

    • Yes it appears to image correctly, meaning it pxe boots and goes through the partclone processes just fine then exits and reboots.
    • I have manually selected Windows Boot Manager and the drive, same result. I have also set the drive first and gotten the same result. All my other machines are set to network boot first, which loads fog, and then fog boots from disk, this has never had any issues.
    • First time deploying to this model and device (I currently only have 1 device of this model but another arriving shortly which I will test with as well).
    • Lenovo ThinkPad E560
    • No, it’s a 500GB SanDisk SSD
    • Windows 8.1 Pro
  • Moderator

    @Shadow00Caster Just to be clear, you can push the image to this target system. It “appears” to image correctly, but on first windows boot it just sits at a flashing cursor? You get the same results if in the bios the machine has the hard drive set first in the boot order?

    Three questions, have you deployed to this model device before?
    What model and make is this target computer?
    Does this system have an M.2 disk?
    OK, last question, what OS are you deploying?

  • I am having the exact same problem.

    I was using 1.2.0 and was getting the non-descriptive error “Unable to register due to these reasons:” (no reasons specified). Note that this 1.2.0 installation has been used successfully with many different Lenovo and Dell model workstations and laptops for Windows 7 and Window 8.1 for the past 2 years. I attempted first to update the kernel to the latest through the web interface, which just hung at transferring to TFTP so I downloaded it and manually put it on the server and ensured the kernel files owner, group and permissions were correct (both matching existing and per the documentation).

    I have now upgraded to latest 1.3.0 from git following the documented installation/upgrade process, all worked flawlessly (props to that). I then proceeded to image the laptop with the now upgraded instance of Fog which worked normally, except upon booting from disk it just sits at the blinking cursor in the top left.

    I have confirmed that UEFI is “disabled”, in that boot is set to legacy only, there is no drive configuration options (such as raid), secure boot disabled, and os defaults disabled (these are all the common bios factors).

    Any assistance would be greatly appreciated.

    I have taken screenshots and pictures of what I believe is all relevant information needed that can be viewed here: https://drive.google.com/folderview?id=0B9ZqDYezvotjenJRNnVyV2RVYW8&usp=sharing

  • Windows 7 will setup a GPT partition layout and install that way if the system it’s installing on is operating in UEFI mode (I think).

  • Moderator

    @Darrell-Lanson How are you installing Windows 7 to a GPT disk?

  • So updating to the FOG trunk fixed my issue with Lenovo E560 not registering now this next one seems to be a Lenovo issue I can image the computer and after reboot I end up with a black screen with the cursor flashing in the corner. I’ve had this happen before and inserting the windows 7 CD in and selecting repair fixes the issue well turns out even though in the BIOS I had legacy only enable UEFI still took over as the drive is partitioned as GPT with NTFS. I still haven’t found a work around yet. I did make a bootable USB stick which will only work on the laptop if I have Legacy First/UEFI if I have it set for LEGACY only it refuses to boot up. I am hoping someone else out there has had to work with these E560 as I haven’t found a guaranteed way of disabling UEFI in the BIOS yet.

  • Moderator

    @Darrell-Lanson If you run the FOG compatibility test (from the advanced iPXE menu I think) What does it say about network support with the 4.5.3 kernels?

  • Well tried it with the latest still no luck I think I will make a VM machine to try the latest trunk and see if that works.