FOG r8020 unable to deploy image (test environment)


  • Moderator

    I quick registered a computer as well as hand registered a new computer for testing. I went and deployed an image to this computer but the deploy task threw an error in the web gui.

    Failed to create deployment tasking for the following hosts
    JIMBOB Failed to start deployment tasking
    Type: 8, File: /var/www/html/fog/lib/fog/fogmanagercontroller.class.php, Line: 59, Message: Undefined variable: whereArray, Host: 192.168.1.205, Username: fog_user
    

    I tried to schedule a capture task and a similar error was thrown in the apache error log but not on the web gui.


  • Moderator

    Deleting and reinstalling the location plugin resolved this issue. Its possible that I had something wrong with the location settings ( I was testing the windows storage node in this environment before ) or something was wrong with the location plugin and was reset when I reinstalled it.

    Marking this solved.

    On a side note. The hostinfo.php query page called from inside the FOS client returned the needed kernel parameters. So I think the concept of usb booting info FOS imaging is looking brighter.


  • Moderator

    @Wayne-Workman I removed the location plugin and the issue went away. Lets see what happens when I add it back in.


  • Moderator

    @george1421 Well those look important. Although I have no idea what they mean lol.

    Using svn you can roll back to specific revisions to find where it was working like this: svn -r xxx up


  • Moderator

    @Wayne-Workman I so wanted to be a wiseguy here and say that I did check the error log (and I did when I posted, there was only complaints about not having a timezone set).

    But this time there is something wrong with the storage node configuration??

    [Tue Jun 07 18:15:59.915028 2016] [:error] [pid 5989] [client 192.168.1.43:4086] PHP Strict Standards:  Only variables should be passed by reference in /var/www/html/fog/lib/pages/schemaupdaterpage.class.php on line 46, referer: http://192.168.1.88/fog/management/?node=schema
    [Tue Jun 07 18:17:32.395065 2016] [:error] [pid 6027] [client 192.168.1.43:4338] PHP Warning:  array_map(): An error occurred while invoking the map callback in /var/www/html/fog/lib/fog/storagegroup.class.php on line 52, referer: http://192.168.1.88/fog/management/index.php?node=host&sub=deploy&id=4&type=1
    [Tue Jun 07 18:18:26.412760 2016] [:error] [pid 6024] [client 192.168.1.43:4507] PHP Warning:  array_map(): An error occurred while invoking the map callback in /var/www/html/fog/lib/fog/storagegroup.class.php on line 52, referer: http://192.168.1.88/fog/management/index.php?node=host&sub=deploy&id=2&type=1
    

  • Moderator

    @george1421 I know it’s tough when it’s YOUR problem, check the apache error logs?


  • Moderator

    Still no joy after the update. I tried to deploy to all 3 systems previously working in the test system with the same results.

    FWIW I get the same error when I query the new hostinfo.php page (was working on the usb boot fos client where I first found the error).


  • Senior Developer

    I say update. I think the error is an attempt to locate a value in the DB that simply doesn’t exist. Therefore the query itself is failing and nothing is being returned to the whereArrayAnd variable.


  • Moderator

    whelp that wasn’t it. Fixing that did some crazy things to the web gui.


  • Moderator

    @george1421 said in FOG r8020 unable to deploy image (test environment):

    /var/www/html/fog/lib/fog/fogmanagercontroller.class.php

    Ah, spotted it.

                 (count($whereArray) ? sprintf('WHERE %s%s',implode(sprintf(' %s ',$whereOperator),$whereArray),($isEnabled ? sprintf(' AND %s',$isEnabled) : '')) : ($isEnabled ? sprintf('WHERE %s',$isEnabled) : '')),
                (count($whereArrayAnd) ? (count($whereArray) ? sprintf('AND %s',implode(sprintf(' %s ',$whereOperator),(array)$whereArrayAnd)) : sprintf('WHERE %s',implode(sprintf(' %s ',$whereOperator),(array)$whereArrayAnd))) : ''),
    

    Looks like the (count($whereArray) should be (count($whereArrayAnd) as in the second line.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.