FOG .32 upgrade to 1.2 issue



  • So here is what happens after the upgrade and it attemps to start apache:
    Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory

    I have looked for the libphp5.so file and it doesn’t exist in this directory only one that is close libphp5filter.so

    Any help would be appreciated



  • I’m from the old school if it ain’t broke don’t touch it with that being said I cannot believe how long I have been using this close to 8 years now and I love it. Had 1 hard drive fail in that time but otherwise going strong.


  • Moderator

    @Tom-Elliott said in FOG .32 upgrade to 1.2 issue:

    Based on the layout, I’m just guessing you’re using Ubuntu?

    You may need to remove the original PHP that was installed.

    Maybe try:

    sudo apt-get purge php5* lib*php*

    Then rerun the installer?

    wiki


  • Developer

    @Darrell-Lanson said in FOG .32 upgrade to 1.2 issue:

    thought so I take it that the servers are a little outdated is there a wiki on what you OS’s are supported. Oh and on a side note I have made a portable fog server using a

    It’s not a matter of what we support, really. Ubuntu 10.04.4 LTS support by Ubuntu ended April 30, 2015.
    I’m happy to hear you got it working, though.



  • OK I have it up and running what are the supported operating systems I thought 10.04.4 was a supported operating system 2 years ago I have 2 of these running one with 1.2 since it came out and just got around to upgrading this one to 1.2 from .32. So I went and checked the one that is running 1.2 since it came out and it’s 10.04.4 just like I thought so I take it that the servers are a little outdated is there a wiki on what you OS’s are supported. Oh and on a side note I have made a portable fog server using a raspberry PI 3 with a 64GB SD Card using Ubuntu 15.10.3 server and FOG 1.2 works like a champ can do my rural locations in a couple of hours saves carrying a big server around basically its a credit card computer.


  • Senior Developer

    @Junkhacker for 1.2.0 location is /var/www/fog/lib/fog/Config.class.php


  • Developer

    @Darrell-Lanson /var/www/fog/lib/fog/config.class.php



  • OK that fixed the apache issue however it didn’t prompt me for the password for MySQL and it looks like the location has moved I looked in the /var/www/fog/commons/config.php but it doesn’t exist where is it now?


  • Developer

    Ubuntu 10.04.4s ? any chance you’re willing to set up a new server on a supported operating system? you can migrate your images and database over.


  • Senior Developer

    Based on the layout, I’m just guessing you’re using Ubuntu?

    You may need to remove the original PHP that was installed.

    Maybe try:

    sudo apt-get purge php5* lib*php*

    Then rerun the installer?


Log in to reply
 

470
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.