Snapin Hash problem with trunk 5623


  • Testers

    I am getting the following in my fog.log on the client when trying to deploy a snapin.

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     6/3/2016 2:39 PM Client-Info Client Version: 0.10.6
     6/3/2016 2:39 PM Client-Info Client OS:      Windows
     6/3/2016 2:39 PM Client-Info Server Version: 7961
     6/3/2016 2:39 PM Middleware::Response Success
     6/3/2016 2:39 PM SnapinClient Snapin Found:
     6/3/2016 2:39 PM SnapinClient     ID: 9289
     6/3/2016 2:39 PM SnapinClient     RunWith:
     6/3/2016 2:39 PM SnapinClient     RunWithArgs:
     6/3/2016 2:39 PM SnapinClient     Name: 02b - Office365-2016 - E3
     6/3/2016 2:39 PM SnapinClient     File: Office365_E3_2016.sfx.exe
     6/3/2016 2:39 PM SnapinClient     Created: 2016-06-03 14:38:20
     6/3/2016 2:39 PM SnapinClient     Args:
     6/3/2016 2:39 PM SnapinClient     Action:
     6/3/2016 2:39 PM Middleware::Communication Download: http://10fogserver/fog/service/snapins.file.php?mac=C0:3F:D5:9C:76:B5||00:00:00:00:00:00:00:E0&taskid=9289
     6/3/2016 2:39 PM SnapinClient C:\Program Files (x86)\FOG\tmp\Office365_E3_2016.sfx.exe
     6/3/2016 2:39 PM SnapinClient ERROR: Hash does not match
     6/3/2016 2:39 PM SnapinClient ERROR: --> Ideal: 23A499F23E8EFC65DB68B9A9B22FBD6CE222B67B1639EA5E6508CB9D8650825D80EE0FBBEF364308CA77A05298B44085F314433129399BC76931E51B0FFBA559
     6/3/2016 2:39 PM SnapinClient ERROR: --> Actual: 5A8DD905396D01E79F8E5C7C1DECFBD46548685D93C1DE18A47151BC649AB2F7DD77298869931D33526FCDE429FE1B934DA210C9ED5944A01E162D0635A8F378
     6/3/2016 2:39 PM Middleware::Communication URL: http://10fogserver/fog/service/snapins.checkin.php?taskid=9289&exitcode=-1&mac=C0:3F:D5:9C:76:B5||00:00:00:00:00:00:00:E0&newService&json
     6/3/2016 2:39 PM Middleware::Communication ERROR: Could not contact FOG server
     6/3/2016 2:39 PM Middleware::Communication ERROR: The remote server returned an error: (500) Internal Server Error.
    ------------------------------------------------------------------------------```
    

    when I goto my server the hash checks out…

    /opt/fog/snapins/ # sha512sum /opt/fog/snapins/Office365_E3_2016.sfx.exe
    23a499f23e8efc65db68b9a9b22fbd6ce222b67b1639ea5e6508cb9d8650825d80ee0fbbef364308ca77a05298b44085f314433129399bc76931e51b0ffba559  /opt/fog/snapins/Office365_E3_2016.sfx.exe
    

    alt text

    Any suggestions?


  • Testers

    Thanks for helping on this Tom.

    After installing the latest trunk to a new VM and importing my db, I failed to realize that I need to update the credentials.
    Thanks for all your help on narrowing this down.


  • Senior Developer

    This issue was the server was updated. When it was updated, he imported his old db information (of which the ftp credentials were changed.). Changing back the information to what was expected, the snapins started working again. This means I will try to figure out a method to transfer the snapin files without FTP using.


  • Moderator

    It could be the file not downloading completely due to sketchy wifi or network, or a bad patch cable or even a bad HDD in the system, or failing RAM. If the checksum doesn’t match, the client won’t use it - this is a security feature.

    Also, what happens when you go to the actual link in the log? I see you typed the IP in the address bar above, but what about the actual link being tried? This one:
    http://10fogserver/fog/service/snapins.checkin.php?taskid=9289&exitcode=-1&mac=C0:3F:D5:9C:76:B5||00:00:00:00:00:00:00:E0&newService&json


  • Senior Developer

    @joe-schmitt

    This is solely on the client at this poitn.


  • Testers

    Was kind of hoping there would be some activity on this thread… Am I the only one having this issue?


Log in to reply
 

470
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.